Bug 1281569 - [RFE][nova]: Versioned notification api
[RFE][nova]: Versioned notification api
Status: CLOSED DUPLICATE of bug 1281570
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: Upstream M3
: 9.0 (Mitaka)
Assigned To: Eoghan Glynn
nlevinki
https://blueprints.launchpad.net/nova...
upstream_milestone_mitaka-3 upstream_...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 15:02 EST by Stephen Gordon
Modified: 2016-06-14 15:20 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-14 15:20:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2015-11-12 15:02:33 EST
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/versioned-notification-api.

Description:

Versioned notification API

Notification interface of nova is not well defined and the current
notifications define a very inconsistent interface. There is no easy
way to see from the notification consumer point of view what is the format
and the content of the notification nova sends.

Nova developers can add new notifications to the system without specifying
the format and the content of the notification.

Moreover developers can change existing notifications without considering
backward compatibility towards the notification consumers.

Due to this situation maintaining a consumer for nova notifications is really
hard.

Specification URL (additional information):

http://specs.openstack.org/openstack/nova-specs/specs/mitaka/approved/versioned-notification-api.html
Comment 2 Jon Schlueter 2016-02-04 09:18:59 EST
This was a Mitaka RFE moving to OSP 9
Comment 3 Mike McCune 2016-03-28 18:33:16 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Stephen Gordon 2016-06-14 15:20:26 EDT

*** This bug has been marked as a duplicate of bug 1281570 ***

Note You need to log in before you can comment on or make changes to this bug.