Bug 1281578 - virt-inspector returns version 6.3 for win10 images (should return 10.0)
virt-inspector returns version 6.3 for win10 images (should return 10.0)
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 15:44 EST by Richard Tollerton
Modified: 2015-11-13 14:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 14:00:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Tollerton 2015-11-12 15:44:12 EST
Allegedly HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\CurrentVersion is now locked at 6.3 (i.e. win8.1) and there are new, undocumented values HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\CurrentMajorVersionNumber and HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\CurrentMinorVersionNumber that need to be checked. cf http://stackoverflow.com/questions/31072543/reliable-way-to-get-windows-version-from-registry.

Workaround is to use ProductName instead.
Comment 1 Richard W.M. Jones 2015-11-12 17:45:33 EST
Oh that is nuts.  Thanks for altering me to this change.
Comment 2 Richard Tollerton 2015-11-12 18:14:34 EST
Related question: I only care about this because virt-install isn't autodetecting --os-variant on an existing disk image (or at least it's not documented as doing so). Should I file a bug report with them on this? Or are virt-manager dependencies on libguestfs a problem?
Comment 3 Richard W.M. Jones 2015-11-13 03:51:50 EST
(In reply to Richard Tollerton from comment #2)
> Related question: I only care about this because virt-install isn't
> autodetecting --os-variant on an existing disk image (or at least it's not
> documented as doing so). Should I file a bug report with them on this? Or
> are virt-manager dependencies on libguestfs a problem?

Yes, file separate bugs for anything that affects a different component.
Comment 4 Richard W.M. Jones 2015-11-13 06:50:24 EST
Untested patch posted:
https://www.redhat.com/archives/libguestfs/2015-November/thread.html#00137
Comment 5 Richard Tollerton 2015-11-13 13:47:05 EST
I have validated the fix in a build from patched master.
Comment 6 Richard W.M. Jones 2015-11-13 13:52:05 EST
For reference, the correct fix was:
https://www.redhat.com/archives/libguestfs/2015-November/msg00141.html
Comment 7 Richard W.M. Jones 2015-11-13 14:00:11 EST
Fixed in 1.31.26.

Note You need to log in before you can comment on or make changes to this bug.