This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1281596 - dnf builddep should be more verbose
dnf builddep should be more verbose
Status: CLOSED DUPLICATE of bug 1148627
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 16:32 EST by Kevin Fenzi
Modified: 2015-11-13 08:50 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 08:50:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2015-11-12 16:32:47 EST
We have switched the Fedora builders over to Fedora 23 and dnf and in this I noticed that 'dnf builddep' isn't as verbose as maintainers might like it to be. 

For example: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=11776173

failed with: 

DEBUG util.py:393:  Error: package octave-devel-6:4.0.0-6.fc24.x86_64 requires octave = 6:4.0.0-6.fc24, but none of the providers can be installed

This was true, but only because it can't install octave, which is because it can't install java-headless which is because it can't install javapackages-tools which is because it can't install python3-javapackages.

Ie, the real dep issue was with python3-javapackages. 

Would it be possible to report the resolver chain that led to not being able to install that 'top level' package? That would be of great help to maintainers when trying to see what package(s) need attention.
Comment 1 Vít Ondruch 2015-11-13 08:50:38 EST

*** This bug has been marked as a duplicate of bug 1148627 ***

Note You need to log in before you can comment on or make changes to this bug.