Bug 1281653 - system-config-selinux does not state dependency on policycoreutils-python
system-config-selinux does not state dependency on policycoreutils-python
Status: CLOSED DUPLICATE of bug 1279046
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 20:50 EST by Tim Landscheidt
Modified: 2015-11-13 04:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 04:29:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Landscheidt 2015-11-12 20:50:06 EST
Description of problem:

On a fresh install of Fedora 23, "dnf install policycoreutils-gui" installs system-config-selinux, but it does not install policycoreutils-python so system-config-selinux cannot be executed.


Version-Release number of selected component (if applicable):

policycoreutils-devel-2.4-14.fc23.x86_64
policycoreutils-gui-2.4-14.fc23.x86_64
policycoreutils-python-2.4-14.fc23.x86_64
policycoreutils-python3-2.4-14.fc23.x86_64
policycoreutils-python-utils-2.4-14.fc23.x86_64

How reproducible:

I tried this only once, but it should still be reproducible.


Steps to Reproduce:
1. (Erase the packages.)
2. Install policycoreutils-gui (which will install policycoreutils-python*3* as a sub-dependency).
3. Run system-config-selinux.


Actual results:

| [root@passepartout ~]# system-config-selinux 
| Traceback (most recent call last):
|   File "/usr/share/system-config-selinux/system-config-selinux.py", line 38, in <module>
|     import booleansPage
|   File "/usr/share/system-config-selinux/booleansPage.py", line 25, in <module>
|     import seobject
| ImportError: No module named seobject
| [root@passepartout ~]#


Expected results:

system-config-selinux should start successfully.
Comment 1 Petr Lautrbach 2015-11-13 04:29:52 EST

*** This bug has been marked as a duplicate of bug 1279046 ***

Note You need to log in before you can comment on or make changes to this bug.