Bug 1281670 - Error log "dovecot: auth: Error: BUG: Authentication client gave a PID 15267 of existing connection" in the maillog
Error log "dovecot: auth: Error: BUG: Authentication client gave a PID 15267 ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dovecot (Show other bugs)
6.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
Frantisek Sumsal
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 00:25 EST by JQK
Modified: 2016-12-20 08:57 EST (History)
4 users (show)

See Also:
Fixed In Version: dovecot-2.0.9-22.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:44:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0929 normal SHIPPED_LIVE dovecot bug fix update 2016-05-10 18:54:00 EDT

  None (edit)
Description JQK 2015-11-13 00:25:17 EST
Description of problem:

Error log "dovecot: auth: Error: BUG: Authentication client gave a PID 15267 of existing connection" in the maillog.

I think it is trigged by following community bug:

http://dovecot.markmail.org/message/ts5bs3vylbm52iax?q=Error:+BUG:+Authentication+client+gave+a+PID#query:Error%3A%20BUG%3A%20Authentication%20client%20gave%20a%20PID+page:1+mid:ts5bs3vylbm52iax+state:results

Version-Release number of selected component (if applicable):

RHEL6.7
dovecot-2.0.9-19.el6_7.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Error log sometimes output.

Expected results:
The issue never happened.

Additional info:
By checking the source code of the newest dovecot(
dovecot-2.0.9-19.el6_7.2) shipped in rhel6.7, the patch is not patched.

By checking the source code of the dovecot(
dovecot-2.2.10-4.el7_0.1) shipped in rhel7.1, the patch is patched in the src/auth/auth/auth-client-connection.c.

So want a backport to the dovecot shipped on rhel6.
Comment 5 errata-xmlrpc 2016-05-10 20:44:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0929.html

Note You need to log in before you can comment on or make changes to this bug.