Bug 1281671 - [rhscl/postgresql-94-rhel7] Postgresql pod is CrashLoopBackOff if using persistent storage
[rhscl/postgresql-94-rhel7] Postgresql pod is CrashLoopBackOff if using persi...
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-postgresql94-docker (Show other bugs)
rh-postgresql94
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Pavel Raiskup
Wenjing Zheng
:
Depends On: 1276326
Blocks: 1281665 1282733
  Show dependency treegraph
 
Reported: 2015-11-13 00:39 EST by wewang
Modified: 2015-12-09 10:17 EST (History)
12 users (show)

See Also:
Fixed In Version: rh-postgresql94-docker-9.4-3
Doc Type: Bug Fix
Doc Text:
A slave container failed to start because of incorrectly located templates for configuration files. The location of these templates has been fixed, and the slave container now starts as expected.
Story Points: ---
Clone Of: 1276326
: 1282733 (view as bug list)
Environment:
Last Closed: 2015-12-09 10:17:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 9 Honza Horak 2015-11-20 05:24:40 EST
Is this something we have a fix for or there is no fix yet?
Comment 12 Ben Parees 2015-11-20 09:47:51 EST
Pavel, it's not so simple as that.  Openshift does things with volume permissions when it provides a persistent volume, so just testing with a standard docker volume is not sufficient to reproduce this.
Comment 13 Pavel Raiskup 2015-11-20 11:01:21 EST
Well, I don't understand this.  Once you have failed container, you probably
see what are the permissions of data directory so you you can really easily
reproduce that without openshift, or?
Comment 15 Martin Nagy 2015-11-25 03:43:35 EST
This looks like the image in question is missing this update: https://github.com/openshift/postgresql/pull/82
Can someone responsible for the images confirm?
Comment 16 Pavel Raiskup 2015-11-25 04:04:13 EST
Confirmed.
Comment 17 Ben Parees 2015-11-25 23:48:55 EST
So this is waiting for the image to be updated?

Note also that there were some permission issues resolved by fixing NFS settings here:
https://bugzilla.redhat.com/show_bug.cgi?id=1282733#c48

which should be applicable to any verification attempt.
Comment 24 errata-xmlrpc 2015-12-09 10:17:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2606.html

Note You need to log in before you can comment on or make changes to this bug.