Bug 1281678 - JSON parse error in batch change bug page
JSON parse error in batch change bug page
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.4
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On: 1255575
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 01:30 EST by Rony Gong
Modified: 2015-12-15 21:14 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.4.10045.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 21:14:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script busy (26.38 KB, image/png)
2015-11-23 21:48 EST, Rony Gong
no flags Details

  None (edit)
Description Rony Gong 2015-11-13 01:30:41 EST
Description of problem:
Javascript error of JSON.parse: expected ',' or '}' in batch move bug page

Go To batch change bugs page: eg 
https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=VERIFIED&bug_status=ASSIGNED&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=RELEASE_PENDING&bug_status=POST&email1=qgong%40redhat.com&emailassigned_to1=1&emailcc1=1&emailreporter1=1&emailtype1=exact&list_id=4164509&order=priority%2Cbug_severity&query_format=advanced&tweak=1

It show JS error in firebug console:
SyntaxError: JSON.parse: expected ',' or '}' after property value in object at line 1 column 19 of the JSON data

return JSON.parse(data);

Go to the detail code line 3293:
			var readData = function($el) {
				var data = attr_data && $el.attr(attr_data);
				if (typeof data === 'string' && data.length) {
					return JSON.parse(data);
				}
				return null;
			};
	

Version-Release number of selected component (if applicable):
Current production(4.4.10042-7)

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Rony Gong 2015-11-23 21:47:25 EST
Retest this on build 4.4.10045-1, Failed
1.Do a search which return mixed bugs, like some bugs are bugzilla, some bugs are fedora bugs.
2.Then click 'Change Several Bugs at Once'
==> CPU cost fully, 100% and page show this script is very busy.
Please check the attachment.

Above error only happens to the mixed bug search list.
Comment 2 Rony Gong 2015-11-23 21:48 EST
Created attachment 1097977 [details]
script busy
Comment 3 Matt Tyson 2015-11-24 19:48:48 EST
This seems to only happen with firefox.  CPU usage goes to 100% for quite some time.

This doesn't seem to happen on Chrome.

I'm currently doing some profiling to find out where the problem is.
Comment 4 Matt Tyson 2015-11-25 23:09:33 EST
(In reply to Rony Gong from comment #1)
> Retest this on build 4.4.10045-1, Failed
> 1.Do a search which return mixed bugs, like some bugs are bugzilla, some
> bugs are fedora bugs.
> 2.Then click 'Change Several Bugs at Once'
> ==> CPU cost fully, 100% and page show this script is very busy.
> Please check the attachment.
> 
> Above error only happens to the mixed bug search list.

Jeff has fixed this by fixing bug 1255575
Comment 5 Rony Gong 2015-11-29 21:21:15 EST
Tested on 
QA environment(bzperfweb01.app.qa) with version(4.4.10045-2, DB: psql)
Result: Pass
Comment 6 Matt Tyson 2015-12-15 21:14:15 EST
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.