Bug 12817 - rpm does not build OK
rpm does not build OK
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: fileutils (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-22 14:47 EDT by Sami Farin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-23 22:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Farin 2000-06-22 14:47:49 EDT
fileutils-4.0s does not build OK:

...
+ strip ./usr/bin/dir ./usr/bin/dircolors ./usr/bin/du ./usr/bin/install
./usr/bin/mkfifo ./usr/bin/shred ./usr/bin/vdir
+ gzip -9nf './usr/share/info/fileutils*'
gzip: ./usr/share/info/fileutils*: No such file or directory
+ exit 0
Processing files: fileutils-4.0s-2
File not found by glob: /var/tmp/fileutils-root/usr/etc/*
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.23789
+ umask 022
...


here fix for .spec file:

--- fileutils.spec~   Thu Jun  1 10:08:05 2000
+++ fileutils.spec    Thu Jun 22 21:25:55 2000
@@ -72,7 +72,7 @@
 %endif
 
   strip .%{_prefix}/bin/* || :
-  gzip -9nf .%{_prefix}/share/info/fileutils*
+  gzip -9nf .%{_prefix}/info/fileutils*
 
   mkdir -p ./etc/profile.d
   install -c -m 644 %SOURCE1 ./etc

but... where does that usr/etc/* come from?
Comment 1 Jeff Johnson 2000-06-22 17:37:02 EDT
You are building using a version of rpm without the rpm configuration that is
being used for Red Hat 7.0. Try upgrading to rpm-3.0.5 located at
	ftp://ftp.rpm.org/pub/rpm/test
and reopen this bug if that doesn't solve your problem.
Comment 2 Sami Farin 2000-06-23 22:20:33 EDT
I used rpm-3.0.5-0.3 but I get the same error with rpm-3.0.5-0.5, too.
Comment 3 Bernhard Rosenkraenzer 2000-06-24 09:01:25 EDT
The spec file was using a hardcoded %{_prefix}/share/info instead of
%{_infodir}, fixed in 4.0u-2. (7.0 will use /usr/share/info because of new FHS
requirements; so replacing it with %{_prefix}/info the way you suggested is not
the right way to fix it.)

Note You need to log in before you can comment on or make changes to this bug.