Bug 1281711 - numad get SIGFPE when use numad with -w
numad get SIGFPE when use numad with -w
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: numad (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: 7.3
Assigned To: Jan Synacek
Petr Sklenar
:
: 1310259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 03:43 EST by Luyao Huang
Modified: 2016-11-04 02:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: numad-0.5-17.20150602git.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luyao Huang 2015-11-13 03:43:58 EST
Description of problem:
numad get SIGFPE when use numad with -w

Version-Release number of selected component (if applicable):
numad-0.5-14.20140620git.el7.x86_64

How reproducible:
100% (on a UMA)

Steps to Reproduce:
1.
# numactl --hard
available: 1 nodes (0)
node 0 cpus: 0 1 2 3
node 0 size: 7365 MB
node 0 free: 197 MB
node distances:
node   0 
  0:  10

2.
# numad -w 5
Floating point exception (core dumped)

3.

Actual results:
numad get SIGFPE when use numad with -w


Expected results:
return 0 node

Additional info:

Program received signal SIGFPE, Arithmetic exception.
0x0000000000407470 in pick_numa_nodes (pid=pid@entry=-1, cpus=500, mbs=0, assume_enough_cpus=assume_enough_cpus@entry=0) at numad.c:2018
2018	        uint64_t prorated_CPU = (process_CPUs * process_MBs[ix]) / mbs;
(gdb) p mbs
$1 = 0
(gdb) bt
#0  0x0000000000407470 in pick_numa_nodes (pid=pid@entry=-1, cpus=500, mbs=0, assume_enough_cpus=assume_enough_cpus@entry=0) at numad.c:2018
#1  0x00000000004022b1 in main (argc=<optimized out>, argv=0x7fffffffdf68) at numad.c:2683
Comment 1 Jan Synacek 2016-07-11 03:17:40 EDT
*** Bug 1310259 has been marked as a duplicate of this bug. ***
Comment 17 errata-xmlrpc 2016-11-04 02:09:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2414.html

Note You need to log in before you can comment on or make changes to this bug.