Bug 1281716 - SELinux prevents rpcbind from shmemnetgrp and getnetgrp operations against nscd
Summary: SELinux prevents rpcbind from shmemnetgrp and getnetgrp operations against nscd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-13 09:23 UTC by Milos Malik
Modified: 2017-08-01 15:10 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-134.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:10:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 0 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description Milos Malik 2015-11-13 09:23:30 UTC
Description of problem:
# systemctl list-unit-files | grep -e nscd -e rpcbind
nscd.service                                  enabled 
rpcbind.service                               static  
nscd.socket                                   enabled 
rpcbind.socket                                enabled 
rpcbind.target                                static  
#

Version-Release number of selected component (if applicable):
nscd-2.17-105.el7.x86_64
rpcbind-0.2.0-32.el7.x86_64
selinux-policy-3.13.1-60.el7.noarch
selinux-policy-devel-3.13.1-60.el7.noarch
selinux-policy-doc-3.13.1-60.el7.noarch
selinux-policy-minimum-3.13.1-60.el7.noarch
selinux-policy-mls-3.13.1-60.el7.noarch
selinux-policy-sandbox-3.13.1-60.el7.noarch
selinux-policy-targeted-3.13.1-60.el7.noarch

How reproducible:
 * sometimes after reboot

Steps to Reproduce:
 * don't know

Actual results (enforcing mode):
----
type=USER_AVC msg=audit(11/13/2015 09:38:57.002:188) : pid=560 uid=nscd auid=unset ses=unset subj=system_u:system_r:nscd_t:s0 msg='avc:  denied  { shmemnetgrp } for  scontext=system_u:system_r:rpcbind_t:s0 tcontext=system_u:system_r:nscd_t:s0 tclass=nscd  exe=? sauid=nscd hostname=? addr=? terminal=?' 
----
type=USER_AVC msg=audit(11/13/2015 09:38:57.003:189) : pid=560 uid=nscd auid=unset ses=unset subj=system_u:system_r:nscd_t:s0 msg='avc:  denied  { getnetgrp } for  scontext=system_u:system_r:rpcbind_t:s0 tcontext=system_u:system_r:nscd_t:s0 tclass=nscd  exe=? sauid=nscd hostname=? addr=? terminal=?' 
----

Expected results:
 * no such USER_AVCs

Comment 3 Lukas Vrabec 2016-06-21 11:21:38 UTC
Milos, 
I cannot reproduce it. Could you look on it please? If we cannot reproduce it, I would like to close it as WORKSFORME

Comment 8 errata-xmlrpc 2017-08-01 15:10:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.