Bug 1281741 - Cannot run tests of carmart-tx quickstart
Cannot run tests of carmart-tx quickstart
Status: VERIFIED
Product: JBoss Data Grid 6
Classification: JBoss
Component: Build (Show other bugs)
6.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.6.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 06:08 EST by Jiri Holusa
Modified: 2018-02-06 14:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Holusa 2015-11-13 06:08:30 EST
During testing of 6.6.0.ER1 testing strange bug appeared when trying to run carmart-tx quickstart tests (however, actual quickstart work fine), link: 

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/JDG/view/FUNC/job/jdg-func-quickstart-tests/QUICKSTART=carmart-tx,jdk=java17_default,label=RHEL6_x86_64/234/console

I wasn't able to reproduce the bug in Jenkins with DR4, but locally yes, it seems to be some Maven magic. However, it's not a good idea to rely on default profile as we agreed with slaskawi. To have a stable setup, it's need to have the source copying inside the testing profile as well.

PR with a fix coming soon.
Comment 2 Jiri Holusa 2015-11-13 06:18:51 EST
PR with the fix: https://github.com/jboss-developer/jboss-jdg-quickstarts/pull/110

Note You need to log in before you can comment on or make changes to this bug.