Bug 1281745 - Updates to HAProxy configuration
Updates to HAProxy configuration
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 06:25 EST by Mike Burns
Modified: 2016-04-07 17:12 EDT (History)
12 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.10-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:12:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 223223 None None None 2016-01-25 06:34 EST
OpenStack gerrit 284274 None None None 2016-02-25 17:05 EST

  None (edit)
Description Mike Burns 2015-11-13 06:25:12 EST
Description of problem:
Based on recent field engagements, we need to update the HAProxy configuration.  The things that we need to ensure:

galera section
 stick-table type ip size should be 1000
 timeout client 60m # or higher
 timeout server 60m # or higher

on the following lines:
 server * check inter 1s port 9200 on-marked-down shutdown-sessions
need to include "backup" keyword


Version-Release number of selected component (if applicable):
7.0

How reproducible:
Always
Comment 1 chris alfonso 2015-12-07 12:17:36 EST
Can you confirm the absence of the backup keyword renders the failover useless? If that's not the case, can you explain what the impact is?
Comment 5 Marios Andreou 2016-01-04 10:41:02 EST
upstream bug report https://bugs.launchpad.net/tripleo/+bug/1530897 

and upstream review for the client/server timeout which afaics is the main missing thing https://review.openstack.org/#/c/263308/


The "stick-table type ip size" thing and backup are both addressed in https://review.openstack.org/#/c/194960/4/manifests/loadbalancer.pp

The only thing still missing afaics upstream is the client/server timeouts, still 0 at https://github.com/openstack/puppet-tripleo/blob/dafdc1f4efde8c57a8c7160ae0162866496089dc/manifests/loadbalancer.pp#L923
Comment 6 Marios Andreou 2016-01-25 06:34:14 EST
the fix at https://review.openstack.org/#/c/263308 abandoned in favor of https://review.openstack.org/#/c/223223 which is merged now (and sets to 90m)

thanks
Comment 10 Ofer Blaut 2016-03-17 12:03:53 EDT
new timeouts are set on controllers


listen mysql
  bind 172.17.1.11:3306 transparent
  option tcpka
  option httpchk
  stick on dst
  stick-table type ip size 1000
  timeout client 90m
  timeout server 90m
  server overcloud-controller-0 172.17.1.13:3306 backup check fall 5 inter 2000 on-marked-down shutdown-sessions port 9200 rise 2
  server overcloud-controller-1 172.17.1.15:3306 backup check fall 5 inter 2000 on-marked-down shutdown-sessions port 9200 rise 2
  server overcloud-controller-2 172.17.1.14:3306 backup check fall 5 inter 2000 on-marked-down shutdown-sessions port 9200 rise 2


openstack-puppet-modules-7.0.13-1.el7ost.noarch
Comment 11 errata-xmlrpc 2016-04-07 17:12:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.