Bug 1281799 - Plank doesn't work with Wayland
Plank doesn't work with Wayland
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: plank (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wesley Hearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 07:46 EST by Khoa
Modified: 2016-12-13 20:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 17:12:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Khoa 2015-11-13 07:46:28 EST
Description of problem:
It seem Plank doesn't work with Wayland
Version-Release number of selected component (if applicable):
Plank version: 0.9.1


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
plank
[FATAL 19:45:42.146345] [AbstractMain:268] Only X11 environments are supported.
[FATAL 19:45:42.146378] Plank will not function properly.

Expected results:


Additional info:
plank -v
[INFO 19:44:28.369400] [AbstractMain:243] Plank version: 0.9.1
[INFO 19:44:28.369458] [AbstractMain:244] Kernel version: 4.2.5-300.fc23.x86_64
[INFO 19:44:28.369495] [AbstractMain:245] GLib version: 2.46.1 (2.45.2)
[INFO 19:44:28.369530] [AbstractMain:248] GTK+ version: 3.18.2 (3.17.3)
[INFO 19:44:28.369562] [AbstractMain:251] Wnck version: 3.14.0
[INFO 19:44:28.369594] [AbstractMain:252] Cairo version: 1.14.2
[INFO 19:44:28.369625] [AbstractMain:253] Pango version: 1.38.1
[INFO 19:44:28.369656] [AbstractMain:255] + Gtk+ CSD support enabled
[INFO 19:44:28.369687] [AbstractMain:258] + Cairo/Gtk+ HiDPI support enabled
[INFO 19:44:28.369719] [AbstractMain:261] + Dynamic Quicklists support enabled
[INFO 19:44:28.369752] [AbstractMain:264] + XInput Barriers support enabled
[FATAL 19:44:28.369795] [AbstractMain:268] Only X11 environments are supported.
[FATAL 19:44:28.369818] Plank will not function properly.
Comment 1 Wesley Hearn 2015-11-30 17:12:16 EST
Due to some technical issues with wayland (see http://glx-dock.org/mr_article.php?b=5&a=73 section about window placement) and the lack of bamf support for Wayland.

So for now I am closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.