This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1281847 - [ppc64le] VM fails to start with a spapr-vscsi interface disk as boot device with message (XML error: target 'sda' duplicated for disk sources)
[ppc64le] VM fails to start with a spapr-vscsi interface disk as boot device ...
Status: CLOSED DUPLICATE of bug 1274677
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
ppc64le Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.1
: ---
Assigned To: Allon Mureinik
Aharon Canan
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 10:18 EST by Carlos Mestre González
Modified: 2016-02-10 14:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 03:54:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm (844.68 KB, text/plain)
2015-11-13 10:26 EST, Carlos Mestre González
no flags Details

  None (edit)
Description Carlos Mestre González 2015-11-13 10:18:39 EST
Description of problem:
Starting a vm fails with a spapr vscsi disk as boot device. Seems having other disks with that interface attached works.

Version-Release number of selected component (if applicable):
vdsm-4.17.10.1-0.el7ev.noarch
vdsm-jsonrpc-4.17.10.1-0.el7ev.noarch
libvirt-client-1.2.17-13.el7.ppc64le
qemu-img-rhev-2.3.0-31.el7_2.1.ppc64le
qemu-kvm-rhev-2.3.0-31.el7_2.1.ppc64le
rhevm-3.6.0.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a vm (with default values, Desktop, Custom OS, no nic)
2. Add a disk with spapr-vscsi interface (My tests were 10GB/ with either iscsi/nfs, sparse or not) - disk starts fine.
3. Start the vm

Actual results:
or] (ForkJoinPool-1-worker-1) [72c52cf1] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: VM test_vm_4 is down with error. Exit message: XML error: target 'sda' duplicated for disk sources '/rhev/data-center/a723a57a-e118-466e-9b8b-63cf66814f17/1bab0f28-536e-446b-80d3-4c4c0e07789e/images/2f06078a-7d90-4414-a2c5-db20395fe194/4450f84d-49e6-4d09-8f0b-06af212295cb' and '<null>'.


Expected results:
vm starts properly

Additional info:
This also happens if you create a boot device with a different interface and then edit the interface to spapr-vscsi.
There doesn't seems to be an issue
Comment 1 Carlos Mestre González 2015-11-13 10:26 EST
Created attachment 1093708 [details]
vdsm
Comment 3 Michal Skrivanek 2015-11-15 03:29:43 EST
Likely a duplicate of bug 1274677
Comment 4 Allon Mureinik 2015-11-15 03:38:09 EST
(In reply to Michal Skrivanek from comment #3)
> Likely a duplicate of bug 1274677
Seems like that. I'll wait for mlibra to confirm refute, as per the needinfo, though.
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-15 06:22:35 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 6 Marek Libra 2015-11-16 03:48:41 EST
Yes, it's a duplicate.
The CDROM is mapped to sda on PPC, same as first bootable disk.
Comment 7 Allon Mureinik 2015-11-16 03:54:01 EST
Thanks Marek.
Closing based on this comment.

*** This bug has been marked as a duplicate of bug 1274677 ***

Note You need to log in before you can comment on or make changes to this bug.