Red Hat Bugzilla – Bug 128185
lvm2 should obsolete not conflict with lvm < 1.0.3-19
Last modified: 2007-11-30 17:10:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Description of problem:
I can't upgrade from lvm (redhat-9) to lvm2 (fedora-2.90) because lvm2
conflicts with lvm. This would work if lvm2 obsoleted lvm instead of
conflicted with it.
Version-Release number of selected component (if applicable):
Steps to Reproduce:
From redhat-9 do:
rpm -U --test \
Actual Results: lvm < 1.0.3-19 conflicts with lvm2-2.00.20-1
Additional info: rpm -q lvm
If you're not using lvm when running the upgrade (ie you have no
logical volumes) then simply remove the lvm rpm first.
But if you *are* using lvm when upgrading, then you should upgrade the
'lvm' rpm as well as installing the lvm2 one. You need the 'lvm'
rpm there for as long as you're using a 2.4 kernel. You want the
'lvm2' rpm when you boot with a 2.6 kernel.
Where is this mythical lvm upgrade that doesn't conflict with lvm2? I
don't see it in fedora-2.90. If it had existed I wouldn't have
considered this a bug.
Don't know where 2.90 is, but the rpm is in FC2:
I'd say that either lvm should be moved into 2.90 or lvm2 should
conflict with it. Otherwise the upgrade from redhat-9 to fedora-2.90
is not self contained.
Dealt with in 2_00_24-2:
Added Obsoletes: lvm < 1.0.3-19 so an 'upgrade' will silently remove
old incompatible lvm packages. Retained the 'conflicts' line so an
'install' of lvm2 will fail if any old lvm package isn't removed or
upgraded first. Added a '%pre' section to ensure that a 2.6 kernel
(or above) is being used during package install. (Otherwise someone
running lvm on a 2.4 kernel could download the 'lvm2' package and
upgrade to it, which would silently remove the lvm tools that are
necessary for them to shut their machine down cleanly.)