Bug 128185 - lvm2 should obsolete not conflict with lvm < 1.0.3-19
lvm2 should obsolete not conflict with lvm < 1.0.3-19
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-19 15:52 EDT by Jim Radford
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-17 11:52:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2004-07-19 15:52:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
I can't upgrade from lvm (redhat-9) to lvm2 (fedora-2.90) because lvm2
conflicts with lvm.  This would work if lvm2 obsoleted lvm instead of
conflicted with it.


Version-Release number of selected component (if applicable):
lvm2-2.00.08-2

How reproducible:
Always

Steps to Reproduce:
From redhat-9 do:

rpm -U --test \
 fedora-2.90/glibc-2.3.3-36.i686.rpm \
 fedora-2.90/shadow-utils-4.0.3-23.i386.rpm \
 fedora-2.90/glibc-devel-2.3.3-36.i386.rpm \
 fedora-2.90/nscd-2.3.3-36.i386.rpm \
 fedora-2.90/glibc-common-2.3.3-36.i386.rpm \
 fedora-2.90/libselinux-1.14.1-1.i386.rpm \
 fedora-2.90/glibc-headers-2.3.3-36.i386.rpm \
 fedora-2.90/tzdata-2003d-2.noarch.rpm \
 fedora-2.90/lvm2-2.00.20-1.i386.rpm \


Actual Results:  lvm < 1.0.3-19 conflicts with lvm2-2.00.20-1

Expected Results: 

Additional info: rpm -q lvm
lvm-1.0.3-17
Comment 1 Alasdair Kergon 2004-08-12 11:30:14 EDT
Not convinced.

If you're not using lvm when running the upgrade (ie you have no
logical volumes) then simply remove the lvm rpm first.

But if you *are* using lvm when upgrading, then you should upgrade the
'lvm' rpm as well as installing the lvm2 one.  You need the 'lvm'
rpm there for as long as you're using a 2.4 kernel.  You want the
'lvm2' rpm when you boot with a 2.6 kernel.
Comment 2 Jim Radford 2004-08-12 14:17:06 EDT
Where is this mythical lvm upgrade that doesn't conflict with lvm2?  I
don't see it in fedora-2.90.  If it had existed I wouldn't have
considered this a bug.
Comment 3 Alasdair Kergon 2004-08-12 14:31:32 EDT
Don't know where 2.90 is, but the rpm is in FC2:

http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/os/Fedora/RPMS/lvm-1.0.3-19.0.i386.rpm

Comment 4 Jim Radford 2004-08-12 14:47:40 EDT
I'd say that either lvm should be moved into 2.90 or lvm2 should
conflict with it.  Otherwise the upgrade from redhat-9 to fedora-2.90
is not self contained.
Comment 5 Alasdair Kergon 2004-09-17 11:52:21 EDT
Dealt with in 2_00_24-2:

Added Obsoletes: lvm < 1.0.3-19 so an 'upgrade' will silently remove
old incompatible lvm packages.  Retained the 'conflicts' line so an
'install' of lvm2 will fail if any old lvm package isn't removed or
upgraded first.  Added a '%pre' section to ensure that a 2.6 kernel
(or above) is being used during package install.  (Otherwise someone
running lvm on a 2.4 kernel could download the 'lvm2' package and
upgrade to it, which would silently remove the lvm tools that are
necessary for them to shut their machine down cleanly.)

Note You need to log in before you can comment on or make changes to this bug.