Bug 1281861 - Automate UI Error: NoMethodError in MiqAeTools#resolve
Automate UI Error: NoMethodError in MiqAeTools#resolve
Status: CLOSED DUPLICATE of bug 1281860
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.5.0
Assigned To: Dan Clarizio
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 11:03 EST by mkanoor
Modified: 2015-11-13 13:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 13:50:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mkanoor 2015-11-13 11:03:23 EST
Description of problem:
When you click on Automate -> Simulation we get a stack trace


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Open the CFME Web UI
2. Select Automation -> Simulation
3.

Actual results:
NoMethodError in MiqAeTools#resolve

undefined method `[]' for nil:NilClass
   %i(containers images instances providers vandt

     images_filter instances_filter templates_filter templates_images_filter containers_filter

     vms_filter vms_instances_filter).include?(x_tree[:type])

  end


  def show_advanced_search?



Trace of template inclusion: app/views/layouts/_footer.html.haml, app/views/layouts/application.html.haml

Rails.root: /Users/madhukanoor/devsrc/manageiq

Application Trace | Framework Trace | Full Trace
app/helpers/application_helper.rb:1290:in `tree_with_advanced_search?'
app/helpers/application_helper.rb:1111:in `show_adv_search?'
app/views/layouts/_adv_search.html.haml:1:in `_app_views_layouts__adv_search_html_haml__424126363523498490_70300482127420'
/Users/madhukanoor/.gem/ruby/2.2.2/bundler/gems/rails-a37d0e57571f/actionview/lib/action_view/template.rb:145:in `block in render'
/Users/madhukanoor/.gem/ruby/2.2.2/bundler/gems/rails-a37d0e57571f/activesupport/lib/active_support/notifications.rb:166:in `instrument’

Expected results:
We should be able to see the Simulation Screen

Additional info:
Comment 2 Dan Clarizio 2015-11-13 13:50:34 EST

*** This bug has been marked as a duplicate of bug 1281860 ***

Note You need to log in before you can comment on or make changes to this bug.