Bug 1281870 - Cinder error when CinderNfsMountOptions option is empty or absent
Cinder error when CinderNfsMountOptions option is empty or absent
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Giulio Fidente
lkuchlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 11:24 EST by Pierre Blanc
Modified: 2016-04-07 17:42 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.8-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:42:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 245225 None None None Never

  None (edit)
Description Pierre Blanc 2015-11-13 11:24:54 EST
Description of problem:

When I deploy director with NFS backend for cinder, sometimes I don't need nfs mount options.
If I choose to omit this option, or if the option is define to '', the deployment fails.

Version-Release number of selected component (if applicable):
Tested on rhel 7.1 with osp-d 7.1

How reproducible:

Deploy with NFS cinder backend, and customized the templates/environments/storage-environment.yaml with this option:

  #### CINDER NFS SETTINGS ####

  ## NFS mount options
  CinderNfsMountOptions: ''
  ## NFS mount point, e.g. '192.168.122.1:/export/cinder'
  CinderNfsServers: '<SERVER>:<PATH>'
 

Actual results:

Deployment failed with this error: 
Nov 13 10:34:10 overcloud-controller-0.localdomain os-collect-config[3952]: Error: Could not find data item cinder_nfs_mount_options in any Hiera data file and no default suppli
ed at /var/lib/heat-config/heat-config-puppet/435aaed1-ef71-42fb-ad51-fc1c11a74315.pp:805 on node overcloud-controller-0.localdomain

Expected results:

A successful deployment.
Comment 5 lkuchlan 2016-03-08 05:10:49 EST
Tested using:
openstack-tripleo-heat-templates-0.8.9-1.el7ost.noarch

Verification instructions:

Deploy with NFS cinder backend, and customized the templates/environments/storage-environment.yaml with this option:

#### CINDER NFS SETTINGS ####

  ## NFS mount options
  CinderNfsMountOptions: ''
  ## NFS mount point, e.g. '192.168.122.1:/export/cinder'
  CinderNfsServers: '10.35.160.111:/export/liron'

Result:

The deployment was finished successfully
Comment 7 errata-xmlrpc 2016-04-07 17:42:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.