Bug 1281882 - rrd_path missing in defaults.py
rrd_path missing in defaults.py
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: check-mk (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrea Veri
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 12:09 EST by Matt Pusateri
Modified: 2016-03-06 21:23 EST (History)
1 user (show)

See Also:
Fixed In Version: check-mk-1.2.6p16-2.fc23 check-mk-1.2.6p16-2.fc22 check-mk-1.2.6p16-2.el7 check-mk-1.2.6p16-2.el6 check-mk-1.2.6p16-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 20:23:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Pusateri 2015-11-13 12:09:41 EST
Description of problem:
This also relates to check-mk-multisite and that might be a better component. I also found several other things I had to fix with check_mk to get multisite working on Centos 6.x I'll file a separate bug on them. 

rrd_path missing from configuration file  


Version-Release number of selected component (if applicable):
check-mk-livestatus-1.2.6p9-1.el6.x86_64
check-mk-1.2.6p9-1.el6.x86_64
check-mk-multisite-1.2.6p9-1.el6.noarch

How reproducible:
Fails out of the box. 

Steps to Reproduce:
1. yum install check-mk check-mk-multisite
2. Configure /etc/httpd/conf.d/{nagios.conf,zzz_check_mk_conf}
3. Start nagios and apache
4. browse to http://server_name/check_mk/

Actual results:
500 Server error
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] mod_python (pid=12210, interpreter='127.0.0.1', phase='PythonHandler', handler='index'): Application error
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] ServerName: '127.0.0.1'
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] DocumentRoot: '/var/www/html'
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] URI: '/check_mk/index.py'
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] Location: None
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] Directory: '/usr/share/check_mk/web/htdocs/'
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] Filename: '/usr/share/check_mk/web/htdocs/index.py'
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] PathInfo: None
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] Traceback (most recent call last):
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 1540, in HandlerDispatch\n    default=default_handler, arg=req, silent=hlist.silent)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 1205, in _process_target\n    module = import_module(module_name, path=path)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 299, in import_module\n    log, import_path)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 683, in import_module\n    execfile(file, module.__dict__)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/share/check_mk/web/htdocs/index.py", line 51, in <module>\n    execfile(pagehandlers_dir + "/" + fn)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/share/check_mk/web/plugins/pages/shipped.py", line 32, in <module>\n    import prediction
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 994, in load_module\n    return _global_modules_cache.import_module(self.__file)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/lib64/python2.6/site-packages/mod_python/importer.py", line 683, in import_module\n    execfile(file, module.__dict__)
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107]   File "/usr/share/check_mk/web/htdocs/prediction.py", line 38, in <module>\n    rrd_path = defaults.rrd_path
[Fri Nov 13 01:29:28 2015] [error] [client 10.10.100.107] AttributeError: 'module' object has no attribute 'rrd_path'

Expected results:


Additional info:

I believe this is b/c check_mk-multisite can integrate with PNP4Nagios which might can do rrd_tools.

Here's what I did to work around it but I'm not sure if it's the right fix as I'm not using rrd_tool.

Added rrd directory to /var/lib/check_mk
drwxr-xr-x. 2 nagios nagios 4096 Nov 13 01:55 rrd

edited /usr/share/check_mk/web/htdocs/defaults.py
added line:
rrd_path                    = '/var/lib/check_mk/rrd'

This seems to be a really old bug back from 2013 that got fixed in the upstream, not sure why it's happening now.

http://lists.mathias-kettner.de/pipermail/checkmk-commits/2013-February/005561.html
Comment 1 Fedora Update System 2016-02-19 14:52:48 EST
check-mk-1.2.6p16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5e44413b03
Comment 2 Fedora Update System 2016-02-19 14:52:49 EST
check-mk-1.2.6p16-1.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d46254c783
Comment 3 Fedora Update System 2016-02-19 14:52:49 EST
check-mk-1.2.6p16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5e44413b03
Comment 4 Fedora Update System 2016-02-19 14:53:02 EST
check-mk-1.2.6p16-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b265e8374d
Comment 5 Fedora Update System 2016-02-19 14:53:03 EST
check-mk-1.2.6p16-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-b86cee6cb6
Comment 6 Fedora Update System 2016-02-20 12:12:18 EST
check-mk-1.2.6p16-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4a7f76bc91
Comment 7 Fedora Update System 2016-02-20 12:12:20 EST
check-mk-1.2.6p16-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-41fedd9ffa
Comment 8 Fedora Update System 2016-02-20 12:12:28 EST
check-mk-1.2.6p16-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-db20dc38ac
Comment 9 Fedora Update System 2016-02-20 12:12:31 EST
check-mk-1.2.6p16-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6565234a4e
Comment 10 Fedora Update System 2016-02-20 12:12:39 EST
check-mk-1.2.6p16-2.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-56173e9c72
Comment 11 Fedora Update System 2016-02-21 01:21:13 EST
check-mk-1.2.6p16-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-41fedd9ffa
Comment 12 Fedora Update System 2016-02-21 01:47:56 EST
check-mk-1.2.6p16-2.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-56173e9c72
Comment 13 Fedora Update System 2016-02-21 01:53:14 EST
check-mk-1.2.6p16-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-db20dc38ac
Comment 14 Fedora Update System 2016-02-21 12:58:16 EST
check-mk-1.2.6p16-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4a7f76bc91
Comment 15 Fedora Update System 2016-02-21 13:27:34 EST
check-mk-1.2.6p16-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6565234a4e
Comment 16 Fedora Update System 2016-02-22 20:22:59 EST
check-mk-1.2.6p16-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-03-02 16:51:25 EST
check-mk-1.2.6p16-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2016-03-05 20:26:26 EST
check-mk-1.2.6p16-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-03-06 17:27:50 EST
check-mk-1.2.6p16-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2016-03-06 21:23:49 EST
check-mk-1.2.6p16-2.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.