Bug 1281892 - packaging: gfind_missing_files are not in geo-rep %if ... %endif conditional
packaging: gfind_missing_files are not in geo-rep %if ... %endif conditional
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks: 1281893
  Show dependency treegraph
 
Reported: 2015-11-13 12:51 EST by Kaleb KEITHLEY
Modified: 2016-06-16 09:44 EDT (History)
0 users

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1281893 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-11-13 12:51:02 EST
Description of problem:

If geo-rep is disabled in the build, gfind_missing_files will be included in the ganesha sub-package

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-11-13 12:57:33 EST
REVIEW: http://review.gluster.org/12577 (packaging: gfind_missing_files not in geo-rep %if ... %endif conditional) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2015-11-16 03:46:07 EST
COMMIT: http://review.gluster.org/12577 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 8ad921e8d61e8b7b1dcd4aaba5d00aafbb55cf2a
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Fri Nov 13 12:55:17 2015 -0500

    packaging: gfind_missing_files not in geo-rep %if ... %endif conditional
    
    if geo-rep is disabled in the build then the gfind_missing_files
    are erroneously included in the ganesha sub-package
    
    Change-Id: I440df7e8283bcc8a80aa057c1c9d6f8034ca98d2
    BUG: 1281892
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/12577
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:44:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.