Bug 1281908 - Cannot set overcloud admin password only in deployment plan
Cannot set overcloud admin password only in deployment plan
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: James Slagle
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 13:58 EST by Stephen Herr
Modified: 2017-07-19 03:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 14:11:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2015-11-13 13:58:24 EST
Description of problem:
If you change the overcloud admin password (Controller-1::AdminPassword) in the deployment plan you have to also change it in /home/stack/tripleo-overcloud-passwords.

Version-Release number of selected component (if applicable):
7

How reproducible:
Always

Steps to Reproduce:
1. Change the Controller-1::AdminPassword to something other than the default randomly-generated one, say 'password'.
2. Deploy the overcloud from the Director

Actual results:
You can log into Horizon with the set password, but you get an error about "compute resources are not available" and the "Hypervisors" tab does not work.

Expected results:
Everything should be aware of the correct admin password

Additional info:
If you also set the password in /home/stack/tripleo-overcloud-passwords then things work correctly.
Comment 2 Mike Burns 2015-11-13 14:11:10 EST
At this point in OSP 7, we're fixing blocker issues only.  This issues appears to have a clear workaround (set the password in 2 places), so it's not blocker.

Since tuskar will not be shipped in OSP 8, this applies only to OSP 7.  

Given that this isn't a blocker and we're not fixing non-blockers, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.