Bug 1281920 - neutron-server will not start: fails with pbr version issue
neutron-server will not start: fails with pbr version issue
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity high
: ---
: Liberty
Assigned To: Jakub Libosvar
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 14:56 EST by David Moreau Simard
Modified: 2016-06-05 19:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-05 19:16:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug information for neutron-server (7.42 KB, text/plain)
2015-11-13 14:56 EST, David Moreau Simard
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1452515 None None None Never
OpenStack gerrit 192842 None None None Never
Gerrithub.io 252334 None None None Never

  None (edit)
Description David Moreau Simard 2015-11-13 14:56:45 EST
Created attachment 1093826 [details]
Debug information for neutron-server

neutron-server from the current liberty delorean repository fails to start.

Relevant information in the attachment.
Comment 1 Alan Pevec 2015-11-13 17:15:38 EST
7.0.1-dev82 is definitely wrong, it should be 7.0.1+dev82
as described in https://github.com/openstack-packages/neutron/commit/96e89cddf4b2335c99ea73168768b5c8a54ed33e
Comment 2 Ihar Hrachyshka 2015-11-15 06:21:56 EST
What's the pbr version you use to build the package? I can't reproduce it locally. Does it include 1c89d18b6beecade6b7c9007b324e8cf0f486e22 patch: https://review.openstack.org/#/c/141606/1 ?
Comment 3 David Moreau Simard 2015-11-15 15:34:26 EST
@Ihar
This is reproducible with the current delorean repositories for liberty. You can see the output of the repolist in the attachment.

Here's an example job that exhibits this issue: https://prod-rdojenkins.rhcloud.com/view/RDO-Liberty-Trunk/job/khaleesi-pipeline-rdo-liberty-delorean-centos-7.0-packstack-all-in-one-neutron-ml2-vxlan-rabbitmq-enforcing-tempest-minimal/86/console
Comment 4 Jakub Libosvar 2015-11-16 12:27:49 EST
I went through pbr code and it passes version [1] pkg_resources that replaces all non-alphanumeric characters into dashes [2]. Maybe the pbr SemVer description [3] is not correct. Is anyone aware of having + character in PBR_VERSION and correctly provided into PKG-INFO in other projects?

[1] https://github.com/openstack-dev/pbr/blob/master/pbr/packaging.py#L359
[2] https://bitbucket.org/pypa/setuptools/src/4ce518784af886e6977fa2dbe58359d0fe161d0d/pkg_resources/__init__.py?at=default&fileviewer=file-view-default#cl-1368
[3] http://docs.openstack.org/developer/pbr/semver.html#semantic-versioning-specification-semver
Comment 5 Alan Pevec 2015-11-16 12:31:07 EST
Please file bug for PBR upstream, code MUST implement semver as specified in [3]
Comment 6 Alan Pevec 2015-11-16 14:43:36 EST
Turns out this is a known issue in upstream PBR with two proposed competing fixes and no resolution yet :(
Comment 7 Mike McCune 2016-03-28 18:47:43 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Assaf Muller 2016-06-05 19:16:59 EDT
This has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.