Bug 1281923 - oo installer fails at openshift_facts for offline installs
oo installer fails at openshift_facts for offline installs
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 15:10 EST by Ryan Howe
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 10:34:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-11-13 15:10:51 EST
Description of problem:
oo installer fails at openshift_facts for offline installs when no Gateway is defined. 

Version-Release number of selected component (if applicable):
3.0.2

How reproducible:


Steps to Reproduce:
1. Install via oo-install-ose on a system that is offline with no Gateway
2. Repos are available 

Actual results:
Installer failed at facts 

Expected results:
Installer to work

Additional info:

Customers Solution

solution was actually to configure a FAKE Gateway in the ifcfg file of a network card..
We set GW as 192.168.138.129 (Master IP) on both master&node (but it should work with any IP in the subnet, because the GW is irrelevant),
and the installation passed that test, and continued to installing packages, and successfully completed.
Comment 1 Jason DeTiberus 2015-11-13 17:14:21 EST
I suspect this is a result of us consuming the upstream facts from Ansible. Can you provide the output of the failed run?

Note You need to log in before you can comment on or make changes to this bug.