Bug 1281927 - [RFE][nova]: [VMware] Enable setting memory, disk and vnic limits [NEEDINFO]
[RFE][nova]: [VMware] Enable setting memory, disk and vnic limits
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity low
: ga
: 9.0 (Mitaka)
Assigned To: Eoghan Glynn
Tzach Shefi
https://blueprints.launchpad.net/nova...
upstream_milestone_mitaka-3 upstream_...
: FutureFeature, TestOnly, Triaged, ZStream
Depends On:
Blocks: 1341917
  Show dependency treegraph
 
Reported: 2015-11-13 15:39 EST by Stephen Gordon
Modified: 2016-08-24 08:52 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-nova-13.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 08:52:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sclewis: needinfo? (sgordon)


Attachments (Terms of Use)
Nova logs (899.32 KB, text/plain)
2016-08-23 08:08 EDT, Tzach Shefi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 179059 None None None Never
OpenStack gerrit 179060 None None None Never
OpenStack gerrit 179061 None None None Never
OpenStack gerrit 179062 None None None Never
OpenStack gerrit 180202 None None None Never
OpenStack gerrit 180942 None None None Never
OpenStack gerrit 187942 None None None Never
OpenStack gerrit 188321 None None None Never
OpenStack gerrit 188789 None None None Never
OpenStack gerrit 192675 None None None Never
OpenStack gerrit 196171 None None None Never
OpenStack gerrit 202768 None None None Never
OpenStack gerrit 204219 None None None Never
OpenStack gerrit 204220 None None None Never
OpenStack gerrit 204221 None None None Never
OpenStack gerrit 208612 None None None Never
OpenStack gerrit 227386 None None None Never

  None (edit)
Comment 4 Mike McCune 2016-03-28 18:33:16 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Tzach Shefi 2016-08-23 07:02:31 EDT
Failed to verify:

1. Disk IO limit - passed. 

2. Disk IO shares level - failed to boot an instance once disk IO share parameters were tested. 

# openstack flavor show disksharelimit2
True                                                               |
| properties                 | quota:disk_io_share_level='High', quota:disk_io_shares_share='850' |
| ram                        | 1024                                                               |

Failed to boot instance Horizon reports ->  Error: Failed to perform requested operation on instance "DiskShareLimit", the instance has an error status: Please try again later [Error: No valid host was found. There are not enough hosts available.]. 



3. 4. Network vif_limit & vif_share_level - can't test don't have prerequisites, see link [1]. My vmware setup is 5.5u3 based not 6, without NSX/vdistributed switch, I don't see such NIC resource settings on VMware's side. 


5. Memory limit - passed.

6. Memory shares level - failed to boot instance with these settings:
# openstack flavor show memorysharelimit
                                                             |
| properties                 | quota:memory_shares_level='high', quota:memory_shares_share='1740' |
| ram                        | 2048                                                           

Failed to boot instance, Horizon reports -> Error: Failed to perform requested operation on instance "memsharelimit", the instance has an error status: Please try again later [Error: No valid host was found. There are not enough hosts available.]. 

"There are not enough hosts" is a bit misleading. 
On same deployment I was later able to boot up a few more instances with a duplicate flavor which didn't include memory share limits. So I had free resources yet when I try to boot an instance based on flavor which included disk or memory share limits I'd get same error. 

Deployment remains up if any one wishes to retest/review this. 
RHEL7.2 
Packstack rhos9 (installed on Aug20)
vmware vcenter/esxi 5.5u3


[1] https://pubs.vmware.com/vsphere-60/index.jsp?topic=%2Fcom.vmware.vsphere.networking.doc%2FGUID-FECAC41A-2C7A-4AD6-B740-7D8D44BADB52.html
Comment 9 Tzach Shefi 2016-08-23 08:08 EDT
Created attachment 1193305 [details]
Nova logs

Not sure how much this helps, check attached nova logs.
look for instance  

780313c6-10d2-4d3a-8a92-42d8688d527c -> nova-compute.log 


564a - - -] [instance: 780313c6-10d2-4d3a-8a92-42d8688d527c] Invalid input received: Share level 'high' cannot have share configured notify_about_instance_usage /usr/lib/python2.7/site-packages/nova/compute/utils.py:284
/var/log/nova/nova-compute.log:2016-08-23 13:49:22.325 24254 DEBUG nova.compute.manager [req-c536c99c-8b9b-40b7-a131-152ef78c02c6 09315ae5287a45d59ad6d5898f818ebf c2bc1778e6b94443a7e9732ab83d564a - - -] [instance: 780313c6-10d2-4d3a-8a92-42d8688d527c] Build of instance 780313c6-10d2-4d3a-8a92-42d8688d527c was re-scheduled: Invalid input received: Share level 'high' cannot have share configured _do_build_and_run_instance /usr/lib/python2.7/site-packages/nova/compute/manager.py:1945
Comment 12 errata-xmlrpc 2016-08-24 08:52:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1761.html

Note You need to log in before you can comment on or make changes to this bug.