Bug 1281936 - (CVE-2015-8241) CVE-2015-8241 libxml2: Buffer overread with XML parser in xmlNextChar
CVE-2015-8241 libxml2: Buffer overread with XML parser in xmlNextChar
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20151008,reported=2...
: Security
Depends On: 1281939 1281937 1281938 1284794 1286495 1286496 1286497 1323035
Blocks: 1274223 1281961 1318206
  Show dependency treegraph
 
Reported: 2015-11-13 15:59 EST by Adam Mariš
Modified: 2017-08-24 14:36 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A denial of service flaw was found in libxml2. A remote attacker could provide a specially crafted XML or HTML file that, when processed by an application using libxml2, would cause that application to leak potentially sensitive information.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2015-11-13 15:59:28 EST
A buffer overread in xmlNextChar was found, causing segmentation fault when compiled with ASAN.

Upstream bug (contains reproducer):

https://bugzilla.gnome.org/show_bug.cgi?id=756263

Upstream patch:

https://git.gnome.org/browse/libxml2/commit/?id=ab2b9a93ff19cedde7befbf2fcc48c6e352b6cbe
Comment 1 Adam Mariš 2015-11-13 16:00:44 EST
Created libxml2 tracking bugs for this issue:

Affects: fedora-all [bug 1281937]
Comment 2 Adam Mariš 2015-11-13 16:00:53 EST
Created mingw-libxml2 tracking bugs for this issue:

Affects: fedora-all [bug 1281938]
Affects: epel-7 [bug 1281939]
Comment 3 Adam Mariš 2015-11-19 06:28:48 EST
Acknowledgments:

Name: the GNOME project
Upstream: Hugh Davenport
Comment 4 Adam Mariš 2015-11-19 07:58:48 EST
CVE assignment:

http://openwall.com/lists/oss-security/2015/11/18/23
Comment 8 errata-xmlrpc 2015-12-07 05:14:55 EST
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2015:2549 https://rhn.redhat.com/errata/RHSA-2015-2549.html
Comment 9 errata-xmlrpc 2015-12-07 07:01:02 EST
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2015:2550 https://rhn.redhat.com/errata/RHSA-2015-2550.html
Comment 13 errata-xmlrpc 2016-05-17 12:14:45 EDT
This issue has been addressed in the following products:



Via RHSA-2016:1089 https://rhn.redhat.com/errata/RHSA-2016-1089.html

Note You need to log in before you can comment on or make changes to this bug.