Bug 1281954 - B0rken in rawhide
B0rken in rawhide
Product: Fedora
Classification: Fedora
Component: nant (Show other bugs)
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Timotheus Pokorra
Fedora Extras Quality Assurance
Depends On:
Blocks: sharpziplib
  Show dependency treegraph
Reported: 2015-11-13 16:47 EST by Raphael Groner
Modified: 2015-11-14 15:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-14 15:55:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-11-13 16:47:29 EST
Description of problem:
Error: nothing provides mono(log4net) = needed by nant-1:0.92-4.fc24.x86_64

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpmbuild foo.spec (with BR: nant)

Actual results:
see error above

Expected results:
no error about nant while mock/rpmbuild runs

Additional info:
Comment 1 Timotheus Pokorra 2015-11-14 04:25:30 EST
I have now triggered a new koji build (nant-0.92-5). 
That should solve the issue.

It seems log4net was updated to 1.2.14, and somehow the required log4net version is calculated during the build of nant. Perhaps if I define a specific Requires for log4net >= 1.2.13, that might solve the problem for the future when log4net is upgraded?
Comment 2 Timotheus Pokorra 2015-11-14 04:44:16 EST
I tried what happens if I add 
Requires: mono(log4net) >= 1.2.14 
to the nant spec file. but the resulting rpm shows:
rpm -q --requires  nant
mono(log4net) >= 1.2.14
mono(log4net) =

That would not help either. So I leave the spec as it is, and if log4net is updated, I will just rebuild nant.
Comment 3 Raphael Groner 2015-11-14 15:55:50 EST
Rebuild of sharpziplib worked with success in rawhide. Close this bug as fixed.

Note You need to log in before you can comment on or make changes to this bug.