Bug 1281992 - [PATCH] Update to python3
[PATCH] Update to python3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-shove (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Orsava
Fedora Extras Quality Assurance
:
Depends On: 1281998
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2015-11-13 20:13 EST by Ralph Bean
Modified: 2016-05-25 12:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-shove-0.6.4-3.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-25 12:12:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add python3 support. (4.04 KB, application/mbox)
2015-11-13 20:13 EST, Ralph Bean
no flags Details
Patch to add python3 support. (4.08 KB, patch)
2016-03-15 07:38 EDT, Charalampos Stratakis
no flags Details | Diff
A new rendition of a Python 3 patch (4.88 KB, patch)
2016-05-11 08:42 EDT, Tomas Orsava
no flags Details | Diff

  None (edit)
Description Ralph Bean 2015-11-13 20:13:13 EST
Created attachment 1093962 [details]
Patch to add python3 support.

Upstream supports it.  We should do it.  :)

This also updates the python macros to the new ones in the packaging guidelines.

It also adds a new dep on python-stuf, which is apparently required but was missing.
Comment 1 Jan Kurik 2016-02-24 08:57:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Charalampos Stratakis 2016-03-15 07:38 EDT
Created attachment 1136560 [details]
Patch to add python3 support.

Modified Ralph Bean's patch so it can be applied to the latest build.

Scratch builds for rawhide and F24:

rawhide:  http://koji.fedoraproject.org/koji/taskinfo?taskID=13353073
f24:      http://koji.fedoraproject.org/koji/taskinfo?taskID=13353161
Comment 3 Charalampos Stratakis 2016-03-15 07:40:21 EDT
Maintainer is it ok to push the changes?
Comment 4 Ralph Bean 2016-03-28 21:40:57 EDT
Could be low hanging fruit to fix this one, Luke.
Comment 5 Tomas Orsava 2016-05-06 11:17:12 EDT
Hi Luke,
as this is a bit of a time sensitive issue, we would really appreciate if you could take a look at the patch as soon as possible.
If you are time constrained right now, I hope you won't mind if we do the review and push the changes ourselves in case you won't respond within a week.

Thank you!
Comment 6 Tomas Orsava 2016-05-11 08:42 EDT
Created attachment 1156131 [details]
A new rendition of a Python 3 patch

So, to go with the trend I also modified the existing (Charalampos') patch. I fixed a name of one dependency and created a macro for the long description so it can be provided in full with each subpackage, as god and the packager intended.

There is a slight problem that the package python2/3-stuf which is a runtime dependency of this package has a bug, which I promptly reported [0], therefore it is not possible to test this package to the full extent until the bug is fixed. 

Nevertheless, I believe the patch is solid and can be pushed, as the packager has not responded in half a year. I hope you won't mind, Luke.

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1335144
Comment 7 Tomas Orsava 2016-05-11 08:50:48 EDT
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=14009308

Note You need to log in before you can comment on or make changes to this bug.