Bug 128204 - 32-bit libpng.so missing
32-bit libpng.so missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libpng (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 22:11 EDT by Erich Hoover
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 14:41:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erich Hoover 2004-07-19 22:11:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040629 Firefox/0.9.1

Description of problem:
32-bit programs looking for libpng.so will not find it (specific
example being MPlayer).
By linking /usr/lib/libpng.so to /usr/lib/libpng.so.3 32-bit programs
looking for libpng.so will work.

Version-Release number of selected component (if applicable):
libpng-1.2.5-6

How reproducible:
Always

Steps to Reproduce:
1. Install FC3T1
2. Configure MPlayer as 32-bit w/GUI, example:
linux32 ./configure --as='as --32' --cc='gcc -m32 -L/usr/lib'
--with-x11libdir=/usr/X11R6/lib --enable-gui


Actual Results:  Configure fails with (configure.log):
/usr/bin/ld: skipping incompatible /usr/lib64/libpng.so when searching
for -lpng
/usr/bin/ld: skipping incompatible /usr/lib64/libpng.so when searching
for -lpng
/usr/bin/ld: cannot find -lpng


Expected Results:  Configures appropriately

Additional info:
Comment 1 Matthias Clasen 2004-08-16 11:27:11 EDT
the unversioned .so symlinks are by policy only in the -devel
packages, which you must have installed to link against a library. Do
you have libpng-devel installed ? Make sure you actually have the i386
one installed if you want to link against 32bit libpng
Comment 2 Erich Hoover 2004-08-16 12:54:34 EDT
Yes, I have libpng-devel installed.  I can't say for certain that new
releases have or have not fixed the problem since I created the
symlink on my own a while back.  Is there a way that I can take a look
at the contents of the new RPM to see if the symlink is in there? (I
know the bug existed back at -6 but libpng-devel is up to -9 now)

[root@COMPHOLIO ~]# rpm -q libpng-devel
libpng-devel-1.2.5-9

Also, it'd be nice if the rpm query command said what architecture an
RPM is for instead of just blankly listing the same package twice. 
Something like this maybe:

[root@COMPHOLIO ~]# rpm -q libpng-devel
libpng-devel-1.2.5-9 (noarch)
[root@COMPHOLIO ~]# rpm -q libpng
libpng-1.2.5-9 (i386)
libpng-1.2.5-9 (x86-64)
Comment 3 Matthias Clasen 2004-08-16 13:08:59 EDT
you can try 

rpm -q --queryformat "%{arch}\n" libpng-devel

to find out for which architectures libpng-devel is installed. But if
you're seeing libpng-devel being listed only once, whereas libpng is
listed twice, that already indicates that libpng-devel is missing for
one of the architectures...
Comment 4 Erich Hoover 2004-08-16 13:29:36 EDT
The mirrors only provide one libpng-devel (so I assumed that it's
technically a noarch package though it's listed as x86-64).  You can
see this if you check out the hiwaay.net mirror
(http://mirror.hiwaay.net/redhat/fedora/linux/core/development/x86_64/Fedora/RPMS/):
libpng-1.2.5-9.i386.rpm                                04-Aug-2004
10:05  150K  
libpng-1.2.5-9.x86_64.rpm                              04-Aug-2004
09:00  153K  
libpng-devel-1.2.5-9.x86_64.rpm                        04-Aug-2004
09:00  175K  
libpng10-1.0.15-9.x86_64.rpm                           04-Aug-2004
08:22  144K  
libpng10-devel-1.0.15-9.x86_64.rpm                     04-Aug-2004
08:22  121K  

I believe that is the correct folder for FC3T1 updates (please correct
me if I'm wrong).  Thanks for the tip to get the architecture from the
query command, for libpng-devel it reports only x86-64:

[root@COMPHOLIO ~]# rpm -q --queryformat "%{arch}\n" libpng-devel
x86_64
Comment 5 Matthias Clasen 2004-08-16 14:41:08 EDT
Thats definitively a mirror problem now. libpng-devel-1.2.5-9 is
available for both i386 and x86_64 in rawhide

Note You need to log in before you can comment on or make changes to this bug.