Bug 1282047 - sddm package update forgets last session setting
sddm package update forgets last session setting
Status: CLOSED DUPLICATE of bug 1240749
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 10:45 EST by Corinna Vinschen
Modified: 2016-03-11 15:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 15:39:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corinna Vinschen 2015-11-14 10:45:12 EST
Description of problem:

  When upgrading sddm from 0.10.0-4 to 0.12.0-5, I noticed that, while
  my last user account was still present by default, my previous session
  setting ("Plasma") has been forgotten, and the session menu presented
  the first entry in the session menu ("MATE" in my case) again.  After
  setting this back to "Plasma", the setting was stable even over multiple
  logout and login.

  After that, downgrading to sddm-0.10.0-4, the same occured.  The session
  menu showed "MATE" again and I had to change this manually back to "Plasma".

  Rinse and repeat.

  So, while the sddm package update preserves the last logged in user
  account (no problem there), for some reason it misses to preserve
  the last session setting. 

Version-Release number of selected component (if applicable):

  Any?  During testing: 0.10.0-4 and 0.12.0-5.

How reproducible:

  Up- or downgrade the sddm package.

Actual results:

  Last session setting is forgotten on package update.

Expected results:

  Last session setting is preserved.


Thanks,
Corinna
Comment 1 Rex Dieter 2016-03-11 15:39:37 EST

*** This bug has been marked as a duplicate of bug 1240749 ***

Note You need to log in before you can comment on or make changes to this bug.