Bug 1282059 - cockpit web interface not showing any information
cockpit web interface not showing any information
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cockpit (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 12:32 EST by jan p. springer
Modified: 2015-12-11 18:49 EST (History)
2 users (show)

See Also:
Fixed In Version: cockpit-0.87-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-11 18:49:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of `journalctl -b|grep cockpit` (58.75 KB, application/x-bzip)
2015-11-16 03:53 EST, jan p. springer
no flags Details
cockpit system tab (71.78 KB, image/png)
2015-11-16 03:55 EST, jan p. springer
no flags Details
cockpit services tab (127.43 KB, image/png)
2015-11-16 03:56 EST, jan p. springer
no flags Details
cockpit containers tab (42.01 KB, image/png)
2015-11-16 03:56 EST, jan p. springer
no flags Details
cockpit logs tab (129.28 KB, image/png)
2015-11-16 03:57 EST, jan p. springer
no flags Details
cockpit storage tab (112.94 KB, image/png)
2015-11-16 03:57 EST, jan p. springer
no flags Details
cockpit networking tab (87.03 KB, image/png)
2015-11-16 03:58 EST, jan p. springer
no flags Details
cockpit accounts tab (36.60 KB, image/png)
2015-11-16 03:58 EST, jan p. springer
no flags Details
cockpit terminal tab (38.28 KB, image/png)
2015-11-16 03:59 EST, jan p. springer
no flags Details
cockpit dashboard (47.32 KB, image/png)
2015-11-16 04:00 EST, jan p. springer
no flags Details
firefox 42 web-console output (15.13 KB, text/plain)
2015-11-16 04:12 EST, jan p. springer
no flags Details

  None (edit)
Description jan p. springer 2015-11-14 12:32:54 EST
Description of problem:

after a default installation of f23 server cockpit starts and can be connected to from a web browser in the same subnet. however the side tabs for displaying or manipulating 'System', 'Services', etc are all blank/empty. journalctl on the server does not show anything relevant (at least to my eye).

Version-Release number of selected component (if applicable):

cockpit-0.83-1.fc23.x86_64
cockpit-bridge-0.83-1.fc23.x86_64
cockpit-docker-0.83-1.fc23.x86_64
cockpit-networkmanager-0.83-1.fc23.noarch
cockpit-shell-0.83-1.fc23.noarch
cockpit-storaged-0.83-1.fc23.noarch
cockpit-ws-0.83-1.fc23.x86_64

How reproducible:

always

Steps to Reproduce:
1. install f23 server
2. connect to <server-name>:9090
3. 

Actual results:

no information for 'System', 'Services', etc side tabs is shown

Expected results:

there should be information in the side tabs

Additional info:

the dashboard seems to work though
Comment 1 Stef Walter 2015-11-16 01:50:14 EST
Could you attach:

 1. A screenshot
 2. Relevant logs from the journal: journalctl -b | grep cockpit
Comment 2 jan p. springer 2015-11-16 03:53 EST
Created attachment 1094772 [details]
output of `journalctl -b|grep cockpit`
Comment 3 jan p. springer 2015-11-16 03:55 EST
Created attachment 1094773 [details]
cockpit system tab
Comment 4 jan p. springer 2015-11-16 03:56 EST
Created attachment 1094774 [details]
cockpit services tab
Comment 5 jan p. springer 2015-11-16 03:56 EST
Created attachment 1094775 [details]
cockpit containers tab
Comment 6 jan p. springer 2015-11-16 03:57 EST
Created attachment 1094776 [details]
cockpit logs tab
Comment 7 jan p. springer 2015-11-16 03:57 EST
Created attachment 1094777 [details]
cockpit storage tab
Comment 8 jan p. springer 2015-11-16 03:58 EST
Created attachment 1094779 [details]
cockpit networking tab
Comment 9 jan p. springer 2015-11-16 03:58 EST
Created attachment 1094780 [details]
cockpit accounts tab
Comment 10 jan p. springer 2015-11-16 03:59 EST
Created attachment 1094781 [details]
cockpit terminal tab
Comment 11 jan p. springer 2015-11-16 04:00 EST
Created attachment 1094782 [details]
cockpit dashboard
Comment 12 jan p. springer 2015-11-16 04:12 EST
Created attachment 1094786 [details]
firefox 42 web-console output
Comment 13 jan p. springer 2015-11-16 04:15:15 EST
added system-log output and some screenshots. while looking at the screenshots i realized that the web interface is working, it's just that i can't scroll to the information. i also added the web-console output from firefox for that session. using google chrome 46 the web interface does work, so i have an alternative.
Comment 14 Stef Walter 2015-11-16 06:03:40 EST
What OS is your browser running on? I can see that it's Firefox 42. It'd be interesting to duplicate this issue.
Comment 15 jan p. springer 2015-11-16 07:35:58 EST
firefox-42.0-2.fc22.x86_64 on fedora 22
Comment 16 Stef Walter 2015-11-19 06:06:29 EST
I can duplicate this. The reason is because Firefox has a window width that is not an even pixel width (in my case 892.5) and I can see this in the inspector. However in the javascript DOM it is reporting an even integer width (in my case 893).

This causes the iframe to overflow down below, as you can see in the screenshots.

I'll work on a fix for this.
Comment 18 Fedora Update System 2015-11-27 16:03:09 EST
cockpit-0.85-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e368240084
Comment 19 Fedora Update System 2015-11-28 21:23:27 EST
cockpit-0.85-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cockpit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-e368240084
Comment 20 Fedora Update System 2015-12-04 06:19:22 EST
cockpit-0.86-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-36d1df063f
Comment 21 Fedora Update System 2015-12-04 11:51:09 EST
cockpit-0.86-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cockpit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-36d1df063f
Comment 22 Fedora Update System 2015-12-10 02:59:26 EST
cockpit-0.87-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-d03331b5ea
Comment 23 Fedora Update System 2015-12-11 01:02:11 EST
cockpit-0.87-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cockpit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-d03331b5ea
Comment 24 Fedora Update System 2015-12-11 18:49:52 EST
cockpit-0.87-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.