Bug 1282068 - Don't show unlocked desktop when waking from sleep
Don't show unlocked desktop when waking from sleep
Status: CLOSED DUPLICATE of bug 713640
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 13:48 EST by Søren Hauberg
Modified: 2015-11-20 07:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 07:51:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Søren Hauberg 2015-11-14 13:48:41 EST
Description of problem:

I often put my laptop (Lenovo Yoga 2 Pro) to sleep by closing the lid. When I open the lid, Fedora (not sure which component) shows me a picture of how my desktop looked when the machine was put to sleep. This picture is shown until the computer is fully awake and is ready to show the lock screen. In principle, this is a really cool feature as my laptop feels much more responsive (it shows something directly when I open the lid), but the current implementation is problematic because it shows my unlocked desktop as it looked before I closed the lid. This is a privacy issue as other people than myself could open the lid, and would then briefly see my desktop as it looks when unlocked.


Version-Release number of selected component (if applicable):


How reproducible:
50% of the time.

Steps to Reproduce:
1. Close laptop lid
2. Open lid
3. Look at picture of unlocked desktop for a little while until a lock screen appears.

Actual results:
I see an unlocked desktop briefly and then a lock screen.

Expected results:
I should be presented with a lock screen.

Additional info:
Comment 1 Florian Müllner 2015-11-20 07:51:32 EST

*** This bug has been marked as a duplicate of bug 713640 ***

Note You need to log in before you can comment on or make changes to this bug.