Bug 128208 - ifup-ipsec not setting route
Summary: ifup-ipsec not setting route
Status: CLOSED DUPLICATE of bug 140654
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-20 05:37 UTC by stef
Modified: 2014-03-17 02:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stef 2004-07-20 05:37:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a1)
Gecko/20040520

Description of problem:
Our configured VPN is called VPN1.
When activating VPN1, it does not add the route on how to get to the
destination network. 
Only by manually adding the route, can we actually ping the
destination network.
Seeing this with FC2 on i386 and x86_64 platforms.


Version-Release number of selected component (if applicable):
initscripts-7.55.1-1

How reproducible:
Always

Steps to Reproduce:
1.Configure a VPN using system-config-network (with ipsec wizard)
2.Activate VPN
3.
    

Actual Results:  No Route added.


Expected Results:  Route added.

Additional info:


$ ifup VPN1
RTNETLINK answers: Network is unreachable

Comment 1 Bill Nottingham 2004-07-20 16:43:37 UTC
network-to-network?

Comment 2 stef 2004-07-20 22:15:23 UTC
It is network to network

Comment 3 Stephen Moore 2004-07-21 04:09:22 UTC
Yes, it is network to network. The ipup command uses the DST variable.
This is the remote machines IP address. Through trial and error we
have discovered that the address has to be the local machines subnet.

Comment 4 Trevor Cordes 2004-12-16 15:38:47 UTC
I believe this and 140654 are the same.

Comment 5 Bill Nottingham 2005-03-10 23:09:41 UTC

*** This bug has been marked as a duplicate of 140654 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:04:30 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.