This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282082 - python-flask-debugtoolbar: Python 3 support [NEEDINFO]
python-flask-debugtoolbar: Python 3 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-flask-debugtoolbar (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yohan Graterol
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2015-11-14 15:14 EST by Francesco Frassinelli (frafra)
Modified: 2016-09-07 06:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-flask-debugtoolbar-0.10.0-3.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 06:51:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
athoscribeiro: needinfo? (yohangraterol92)
mhroncok: needinfo? (yohangraterol92)


Attachments (Terms of Use)
Patch adding python 3 support (3.39 KB, patch)
2016-07-22 16:04 EDT, Athos Ribeiro
no flags Details | Diff
Patch adding python 3 support (3.61 KB, patch)
2016-07-26 12:30 EDT, Athos Ribeiro
no flags Details | Diff
Patch adding python 3 support (4.03 KB, patch)
2016-07-27 08:27 EDT, Athos Ribeiro
no flags Details | Diff

  None (edit)
Description Francesco Frassinelli (frafra) 2015-11-14 15:14:31 EST
Flask-DebugToolbar supports Python 3 since v0.9.0 (2014-01-03).

Latest upstream release: 0.10.0 (2015-04-17)
Current version/release in Fedora Rawhide: 0.9.2.

https://fedoraproject.org/wiki/Packaging:Python
https://fedoraproject.org/wiki/Changes/Python_3_as_Default
Comment 1 Jan Kurik 2016-02-24 08:57:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Petr Viktorin 2016-04-19 09:32:40 EDT
Yohan, do you need any help with adding Python 3 support?
Comment 3 Athos Ribeiro 2016-07-22 16:04 EDT
Created attachment 1182936 [details]
Patch adding python 3 support

Hello,

I prepared a patch to including subpackages for python 2 and 3 and also updated this package to the latest version.

Since this is my first python 3 porting attempt, it would be nice to review before applying.

I also changed the link where license and changelog files are retrieved from so we can have the ones for the correct version of the package.

Thanks
Comment 4 Athos Ribeiro 2016-07-22 16:09:22 EDT
Here is a COPR build: https://copr.fedorainfracloud.org/coprs/ribeiro/fedora/build/406450/
Comment 5 Athos Ribeiro 2016-07-26 12:30 EDT
Created attachment 1184327 [details]
Patch adding python 3 support

There were a few mistakes in the former patch: subpackages were named python-Flask* instead of python-flask*

Here is an updated patch and a copr build.

New COPR build: https://copr.fedorainfracloud.org/coprs/ribeiro/fedora/build/422739/
Comment 6 Lumír Balhar 2016-07-27 05:59:45 EDT
Hello.

Your patch looks good to me, but I have two suggestions:

- Could you use a global variable for 'flask-debugtoolbar', which is in specfile many times? (name, url, subpackages name ...)
- It's better to use %license macro for license files

What do you think about it?
Comment 7 Athos Ribeiro 2016-07-27 08:27 EDT
Created attachment 1184638 [details]
Patch adding python 3 support

(In reply to Lumír Balhar from comment #6)
> Hello.
> 
> Your patch looks good to me, but I have two suggestions:
> 
> - Could you use a global variable for 'flask-debugtoolbar', which is in
> specfile many times? (name, url, subpackages name ...)
> - It's better to use %license macro for license files
> 
> What do you think about it?

I agree. I kept changes in the package not related to the python 3 porting to a minimum. Shouldn't it also require or at least recommend python-flask?

Here is another patch with the proposed suggestions
Comment 8 Lumír Balhar 2016-07-28 07:43:56 EDT
Thank you for your update. Patch is now ok and it can be pushed. There was no Require for python-flask so we can stay in this state. Also, the maintainer can add some Requires later.
Comment 9 Lumír Balhar 2016-07-28 07:45:00 EDT
Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=15047843
Comment 10 Miro Hrončok 2016-08-16 06:47:14 EDT
Yohan,
do you mind if I push this? If you don't reply in a week, I assume it's OK.

Note You need to log in before you can comment on or make changes to this bug.