Bug 1282092 - Segfaults every time upon IMAP login; rolling back to F22 RPM instead works
Summary: Segfaults every time upon IMAP login; rolling back to F22 RPM instead works
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: alpine
Version: 23
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Joshua Daniel Franklin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-14 21:30 UTC by David Anderson
Modified: 2016-12-20 15:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-20 15:54:10 UTC


Attachments (Terms of Use)

Description David Anderson 2015-11-14 21:30:23 UTC
Description of problem:

Alpine segfaults upon IMAP login, every time.

Version-Release number of selected component (if applicable):

alpine-2.20-2.fc23.i686.rpm

How reproducible:

Every time

Steps to Reproduce:
1. Run alpine
2. Login to inbox via IMAP


Actual results:

Segfaults. The server is dovecot 2.2.10.


I rolled back to alpine-2.20-2.fc22.i686.rpm (i.e. the current Alpine RPM from Fedora 22 instead of Fedora 23) - this works perfectly.

Comment 1 Walter Neumann 2016-01-22 02:53:48 UTC
I have the same problem with alpine-2.20-2.fc23.i686.rpm: it crashes on opening with the message:

  Problem detected: "Received abort signal(sig=11)"

I thought it might be a problem with my .pinerc but if I remove it alpine gives me the welcome window and whatever I do next I get the same crash (and a copy of the default .pinerc is created).

Rolling back to alpine-2.20-2.fc22.i686.rpm works fine.

Comment 2 Rex Dieter 2016-01-22 17:28:43 UTC
Possible to get a backtrace or abrt report?


Fwiw, I don't see crashes on x86_64, connecting to my office365/imap accounts.


Can you test this build?
http://koji.fedoraproject.org/koji/taskinfo?taskID=12650332

Comment 3 David Anderson 2016-01-23 20:34:05 UTC
That one works for me.

Comment 4 Rex Dieter 2016-01-24 13:44:36 UTC
OK, seems hardening *may* have something to do with it, still, I'd like to document the evidence with a backtrace if possible before considering issuing any official updates.

$ sudo debuginfo-install alpine

$ sudo dnf install gdb

$ gdb alpine

(then type 'run'), and run as usual until it crashes and you get back to a

gdb>

prompt, then type:  thread apply all backtrace


and paste the output here.

(or let abrt submit it, it should be catching this too)

Comment 5 David Anderson 2016-01-25 12:59:26 UTC
Here you go:

* * *

(gdb) thread apply all backtrace

Thread 3 (Thread 0xb7129b40 (LWP 17004)):
#0  0xb7a862e8 in clone () from /lib/libc.so.6
#1  0x003d0f00 in ?? ()
#2  0x00000000 in ?? ()

Thread 2 (Thread 0xb7fd7b40 (LWP 17002)):
#0  0x80060c70 in _Unwind_Resume@plt ()
#1  0x80085b78 in __pthread_cleanup_routine (__frame=<synthetic pointer>) at /usr/include/pthread.h:611
#2  do_after (data=0x8062ce98) at after.c:166
#3  0xb7b61452 in start_thread () from /lib/libpthread.so.0
#4  0xb7a862fe in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7582b00 (LWP 16997)):
#0  0xb7a862e8 in clone () from /lib/libc.so.6
#1  0xb7129b40 in ?? ()
#2  0x00000000 in ?? ()

* * *

Abrt isn't active. The machine is a 10 year-old Pentium 4 (but still in active daily use), so I needed to minimise the amount of background stuff running.

Comment 6 David Anderson 2016-01-25 13:00:12 UTC
P.S. There's also this message:

Missing separate debuginfos, use: dnf debuginfo-install bzip2-libs-1.0.6-19.fc23.i686 krb5-libs-1.14-4.fc23.i686 sssd-client-1.13.3-1.fc23.i686 systemd-libs-222-10.fc23.i686


But, doing that results in a message that no debuginfo package exists for bzip2-libs.

Comment 7 Rex Dieter 2016-01-25 13:12:41 UTC
That backtrace doesn't seem to include any actual crash, are you sure it crashed ???

Comment 8 David Anderson 2016-01-25 13:39:07 UTC
Yes - there's this printed before I run the 'thread apply all' command:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7fd7b40 (LWP 1402)]                                                     
0x80060c70 in _Unwind_Resume@plt ()

Comment 9 Eduardo Chappa 2016-01-31 23:00:20 UTC
(In reply to David Anderson from comment #5)

> [omit backtrace...]
> Abrt isn't active. The machine is a 10 year-old Pentium 4 (but still in
> active daily use), so I needed to minimise the amount of background stuff
> running.

This is hard to figure out, but here is an idea. If you have colors enabled, disable them and try again. My hunch is that it is the color code that is causing this.

-- 
Eduardo

Comment 10 David Anderson 2016-02-01 10:20:50 UTC
Hi Eduardo,

I don't have colours enabled - I'm not entirely sure which feature this refers to, but I can say that there's only monotone colours, and in the config, all settings that mention "color" are off.

David

Comment 11 Eduardo Chappa 2016-02-02 19:58:22 UTC
(In reply to David Anderson from comment #10)

> I don't have colours enabled 

My suggestion is that you build the package by yourself. In some instances this cures the problem. Thank you.

-- 
Eduardo

Comment 12 Maurizio Paolini 2016-02-04 10:36:44 UTC
Here at our department we have the same problem, after upgrading from fedora 22
to fedora 23:

$ alpine


Problem detected: "Received abort signal(sig=11)".
Alpine Exiting.
$

installed version: alpine-2.20-2.fc23.i686

Comment 13 Rex Dieter 2016-02-04 12:42:58 UTC
Can you test the build from comment #2 ?  Does that help for you too?  If so, until this is sorted out, we can disable hardening.

Comment 14 Maurizio Paolini 2016-02-04 21:14:20 UTC
I tested it and it works!

Comment 15 Maurizio Paolini 2016-02-04 21:17:28 UTC
I should have mentioned that we have i686 architecture in all three machines where we use alpine.  Maybe x64 is unaffected.

Comment 16 Maurizio Paolini 2016-02-16 15:12:17 UTC
Are there any news?  I am available for testing, if necessary.  Otherwise
it seems mandatory to produce a new rpm with hardening disabled.

Comment 17 Fedora Update System 2016-02-16 18:25:15 UTC
alpine-2.20-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cc15560960

Comment 18 Fedora Update System 2016-02-17 06:26:16 UTC
alpine-2.20-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cc15560960

Comment 19 Walter Neumann 2016-02-17 14:35:16 UTC
I just tried alpine-2.20-1.fc23.i686 in updates-testing and I still have the same problem: it crashes on opening with the message:

  Problem detected: "Received abort signal(sig=11)" 

Reverting to alpine-2.20-2.fc22.i686 fixes it for me.

Comment 20 Walter Neumann 2016-02-17 14:40:45 UTC
Sorry, ignore the above (and fix the fedora instructions). Following instructions, I did:

dnf install alpine --enablerepo=updates-testing

which should have installed alpine-2.20-4.fc23 but it installed alpine-2.20-1.fc23

Comment 21 Rex Dieter 2016-02-17 14:52:40 UTC
Maybe wait a bit, the push notification above was only for fedora's primary mirror, there is always some delay before it propogates to all other mirrors.

Comment 22 Walter Neumann 2016-02-18 16:56:41 UTC
Thanks for the advice to wait. alpine-2.20-4.fc23 is working fine for me.

Comment 23 Fedora Update System 2016-02-26 07:22:23 UTC
alpine-2.20-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora End Of Life 2016-11-24 13:25:41 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 25 Fedora End Of Life 2016-12-20 15:54:10 UTC
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.