Bug 1282108 - python3 support
python3 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-django-avatar (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2015-11-14 17:48 EST by Adolfo Fitoria
Modified: 2016-09-07 06:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-django-avatar-3.0.0-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 06:52:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch to provide Python 3 subpackage (5.52 KB, patch)
2016-07-31 02:55 EDT, Jan Beran
no flags Details | Diff
Updated spec file which includes also testing now (5.81 KB, patch)
2016-08-05 08:33 EDT, Jan Beran
no flags Details | Diff
New specfile (6.17 KB, text/x-matlab)
2016-08-10 06:56 EDT, Lumír Balhar
no flags Details

  None (edit)
Description Adolfo Fitoria 2015-11-14 17:48:13 EST
Django-avatar supports Python 3 

Latest upstream release: 2.1.1 (2015-08-10)
Current version/release in Fedora Rawhide: 2.0a1-7.20120609git097ed8.fc23

https://fedoraproject.org/wiki/Packaging:Python
https://fedoraproject.org/wiki/Changes/Python_3_as_Default
Comment 1 Jan Kurik 2016-02-24 08:57:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Jan Beran 2016-07-31 02:55 EDT
Created attachment 1185927 [details]
Spec file patch to provide Python 3 subpackage

Changes in the spec file:
- update to version 3.0.0
- url and source update
- modernized specfile with Python 3 packaging
- %changelog correction to avoid a following error:

$ rpmlint python-django-avatar.spec
python-django-avatar.spec: E: specfile-error warning: bogus date in %changelog: Fri Jun 09 2012 Praveen Kumar <kumarpraveen.nitdgp@gmail.com> - 2.0a1-1.20120609git097ed8
0 packages and 1 specfiles checked; 1 errors, 0 warnings.
Comment 3 Jan Beran 2016-08-05 08:33 EDT
Created attachment 1187879 [details]
Updated spec file which includes also testing now
Comment 4 Lumír Balhar 2016-08-10 06:56 EDT
Created attachment 1189568 [details]
New specfile

Hello Jan.

Thank you for your effort. During review of new specfile I've found that %check section failing because there are a lot of missing tests dependencies. I've added them to specfile and I am providing new version.

Rest of specfile looks good to me and it is prepared to push. If maintainer has nothing against, we can push it in one week.

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15200686

Note You need to log in before you can comment on or make changes to this bug.