Bug 1282138 - boot messages missing and do not appear in boot.log
boot messages missing and do not appear in boot.log
Status: CLOSED DUPLICATE of bug 1280452
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Heinrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 22:07 EST by Ronald Wahl
Modified: 2016-09-20 00:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-06 16:48:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Wahl 2015-11-14 22:07:28 EST
Description of problem:
The boot messages are missing after "Starting Switch Root" message (graphical boot disabled). They are also missing from the /var/log/boot.log file but there are different behaviours seen:

(1) It contains the same messages printed on the boot screen, i.e. the last is 
"Starting Switch Root" followed by <ESC>%G (seen with a hexdump utility like hexdump or xxd)
(2) It contains only <ESC>%G
(3) It is empty

When removing the "quiet" switch from the kernel command line the log seems to be complete (but also contains the kernel messages). All in all it looks like a race condition. Maybe a bug in the parser in rsyslog with escape sequences.

Upstream has already 0.8.14 and the ChangeLog lists some parsing bugs - not sure if this bug is fixed as well in that release.

Version-Release number of selected component (if applicable):
rsyslog-8.10.0-1.fc23.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Boot F23 without rhgb on the kernel command line
2. Watch boot messages
3. Check /var/log/boot.log

Actual results:
Boot messages missing after "Starting Switch Root".
/var/log/boot.log incomplete as well.

Expected results:
All boot messages shown on console and in /var/log/boot.log

Additional info:
Currently I run a rather minimal installation (no graphical desktop) in a QEMU/KVM from SSD. That means boot is very fast. Maybe the timing is different when running not in a VM and on slower storage. Just in case you cannot reproduce the behaviour.
Comment 1 Ronald Wahl 2015-11-14 22:26:13 EST
One thing is just coming to my mind: The messages on the boot screen are not printed by rsyslogd, are they? I.e. only the boot.log is written by rsyslogd. So actually the culprit may not be in rsyslogd itself. Any idea where the message get lost?
Comment 2 Ronald Wahl 2015-12-06 16:48:26 EST

*** This bug has been marked as a duplicate of bug 1280452 ***

Note You need to log in before you can comment on or make changes to this bug.