Bug 1282157 - gnome-software hangs system
gnome-software hangs system
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 01:44 EST by Alar Suija
Modified: 2017-01-14 09:23 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 10:54:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alar Suija 2015-11-15 01:44:43 EST
Description of problem:

Gnome-software makes system hard freeze.

Version-Release number of selected component (if applicable):

gnome-software-3.18.3-1.fc23.x86_64

How reproducible:

allways

Steps to Reproduce:

1. Start Software
2. wait 2-3 seconds
3. System freezes hard, if in this moment was disk activity, hard disk LED remains lit


Actual results:

System not responding in any way (e.g. can not switch to virtual console, no ping answer etc)

Expected results:

Software works as expected or at least not hangs computer.

Additional info:

Hardware- Lenovo X61, 2 GB RAM, Intel 965GM graphics. This is absolute vanilla install (x64 live image + updates, no additional software or repos, did fresh install because i was unable solve same problem after upgrading F22>F23). There is no traces in logs. DNF / rpm works O.K. using command prompt.
Bug is not reproducable in my other F23 systems (all x64).
Comment 1 Kalev Lember 2015-11-15 11:55:39 EST
I would guess it's a hardware driver bug, graphics driver maybe?
Comment 2 Alar Suija 2015-11-15 12:03:20 EST
Negative, using gnome-software over remote X causes freeze.
Comment 3 Kalev Lember 2015-11-15 12:06:33 EST
Another idea is that fwupd might be poking the hardware the wrong way. Does it work better if you rm /usr/lib64/gs-plugins-8/libgs_plugin_fwupd.so and killall gnome-software to make sure it's not already running and start it again?
Comment 4 Alar Suija 2015-11-15 12:13:08 EST
Yes, this works.
Comment 5 Richard Hughes 2015-11-16 04:47:23 EST
If you run "sudo /usr/libexec/fwupd/fwupd --verbose" does that lockup the computer? What's the last log message on the console when that happens? Thanks.
Comment 6 Alar Suija 2015-11-16 08:42:32 EST
Yes, this freezes computer. There are only two timestamped lines in output-

timestamp   Verbose debugging enabled (on console 1)
timestamp   Loading fallback values from /etc/fwupd.conf
Comment 7 Christian Dersch 2015-12-18 09:49:25 EST
Can confirm to get this @ThinkPad R400 too.
Comment 8 Richard Hughes 2015-12-18 12:59:22 EST
I'm guessing setting EnableOptionROM=false in /etc/fwupd.conf make things work? If so, that's a kernel bug that needs to be reported. Reading some ROM shouldn't hard-lock the system.
Comment 9 Alar Suija 2015-12-18 13:38:30 EST
Yes, this works for me.
Comment 10 Athmane Madjoudj 2015-12-24 09:24:53 EST
I can confirm the same issue on Thinkpad T400.

Nothing interesting in journal :(

]# /usr/libexec/fwupd/fwupd --verbose

15:13:59        Verbose debugging enabled (on console 1) 

[SYSTEM HANGS]


Setting EnableOptionROM=false fixed the issue.
Comment 11 Richard Hughes 2016-01-11 07:48:30 EST
What does this report on those systems:

find /sys/devices -name "rom"

Also, can you find out *which" rom hangs the system doing "echo 1 > the_long_sysfs_path" and then "cat the_long_sysfs_path > /dev/null" -- thanks!
Comment 12 Alar Suija 2016-01-11 13:43:29 EST
/sys/devices/pci0000:00/0000:00:02.0/rom
/sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/rom

Second rom hangs my system, but it takes 2 attemps, first it gives me i/o error at "cat /sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/rom > /dev/null"

After repeating both commands system hangs.
Comment 13 Manoj 2016-02-11 21:22:13 EST
same issue with Lenovo z460 and enableOptionROM = false solved the problem.
Comment 14 alphaomega 2016-07-11 09:55:02 EDT
This bit me pretty hard when upgrading Fedora 23 to Fedora 24.
After 'dnf system-upgrade reboot' the machine would just freeze at boot. I also had the issue of gnome-software freezing my system on Fedora 23.

It was hard to locate this issue, as journalctl didn't show anything AND the boot process did proceed a while longer after fwupd was started, so it wasn't the last thing that happened during the boot that caused the freeze.

enableOptionROM=false sorted it for me as well.

My machine is a stationary core i5 with a GeForce 200 running neuveau (though I had the same issue with gnome-software when I ran the nVidia proprietary driver).
Comment 15 alphaomega 2016-07-13 02:37:37 EDT
More info:

$ find /sys/devices/ -name "rom"
/sys/devices/pci0000:00/0000:00:03.0/0000:01:00.0/rom
/sys/devices/pci0000:00/0000:00:1c.4/0000:05:00.0/rom
/sys/devices/pci0000:00/0000:00:1c.5/0000:04:00.0/rom
/sys/devices/pci0000:00/0000:00:1c.7/0000:02:00.0/rom

The relevant part of 'lspci -nn'
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 03)
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 01)
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 01)

Doing the 'echo 1 > long_sys_path; cat long_sys_path > /dev/null'
The revision 3 RTL8111 throws an I/O error when reading the ROM.
The revision 1 RTL8111's both immediately hangs the computer.
Comment 16 Glen Turner 2016-11-08 20:27:39 EST
Dell XPS 13 9350 (released 2016). BIOS 1.4.4 (2016-06-14).

$ find /sys/devices/ -name "rom"
/sys/devices/pci0000:00/0000:00:02.0/rom
$ lspci -nn | fgrep '00:02.0' 
00:02.0 VGA compatible controller [0300]: Intel Corporation Iris Graphics 540 [8086:1926] (rev 0a)

"enableOptionROM = false" works around issue.
Comment 17 Fedora End Of Life 2016-11-24 08:25:49 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Fedora End Of Life 2016-12-20 10:54:14 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 19 Glen Turner 2017-01-14 09:23:20 EST
System in #16 now hangs hard after pkcon run an update of Fedora 25. /etc/fwupd.conf contains EnableOptionROM=false.

$ rpm -q gnome-software
gnome-software-3.22.4-2.fc25.x86_64

$ uname -a
Linux petra.aarnet.edu.au 4.8.16-300.fc25.x86_64 #1 SMP Fri Jan 6 18:11:49 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ find /sys/devices -name "rom"
/sys/devices/pci0000:00/0000:00:02.0/rom

$ lspci -nn -k -s '00:02.0'
00:02.0 VGA compatible controller [0300]: Intel Corporation Iris Graphics 540 [8086:1926] (rev 0a)
	Subsystem: Dell Device [1028:0704]
	Kernel driver in use: i915
	Kernel modules: i915

Note You need to log in before you can comment on or make changes to this bug.