Bug 128216 - GFS main packages are built for all architectures (i686, athlon)
GFS main packages are built for all architectures (i686, athlon)
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 05:42 EDT by Jos Vos
Modified: 2010-01-11 21:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 16:19:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2004-07-20 05:42:35 EDT
Description of problem:
When building GFS for i686 and athlon, not only the modules subpackage
is built, but also the GFS and GFS-devel packages.  IMHO these
packages should only be built for the base architecture (i386 in this
case), just as it is done with some other packages (like the way the
kernel-source package is only built for i386). Is this a correct
assumption?

Version-Release number of selected component (if applicable):
GFS-6.0.0-7
Comment 1 Chris Feist 2004-11-30 16:19:42 EST
Ideally we wouldn't build i686 & althlon for GFS & GFS-devel packages,
but because of the problems with excluding arch's in the top level
package, and including the arch in a subpackage it probably isn't
possible without rewriting a large portion of the spec file.

Also, in the past athlon & i686 packages were available which could
cause possible breakage to people who are upgrading their packages.

Note You need to log in before you can comment on or make changes to this bug.