Bug 1282186 - The iotop package for Fedora doesn't support python3 while upstream does
Summary: The iotop package for Fedora doesn't support python3 while upstream does
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iotop
Version: 23
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY3PATCH-PUSH
TreeView+ depends on / blocked
 
Reported: 2015-11-15 11:14 UTC by dperson
Modified: 2016-05-06 12:14 UTC (History)
4 users (show)

Fixed In Version: iotop-0.6-10.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-26 18:11:08 UTC


Attachments (Terms of Use)
Python3 only and SPEC file cleanup patch (4.26 KB, patch)
2016-02-29 16:11 UTC, Charalampos Stratakis
no flags Details | Diff
Python3 only and SPEC file cleanup patch (4.22 KB, patch)
2016-03-07 15:00 UTC, Charalampos Stratakis
no flags Details | Diff

Description dperson 2015-11-15 11:14:05 UTC
Description of problem:
Since version 0.5 iotop has supported python 3 (http://guichaz.free.fr/iotop/NEWS), but the 0.6 (current) package is dependant on python v2.

Version-Release number of selected component (if applicable):
0.6

How reproducible:
100%

Steps to Reproduce:
1. Install the package: sudo dnf install iotop
2. It will require python
3. There is no step 3 =)

Actual results:
The python (not base python3) package is a dependency.

Expected results:
The default installed python3 to provide python for the package.

Additional info:

Comment 1 Charalampos Stratakis 2016-02-29 16:11:52 UTC
Created attachment 1131606 [details]
Python3 only and SPEC file cleanup patch

For Fedora >= 24 Python 3 is the default. This patch fixes the requirements to be only for Python 3 and also some additional SPEC file cleanup and fixes.

Comment 2 Charalampos Stratakis 2016-03-07 15:00:03 UTC
Created attachment 1133819 [details]
Python3 only and SPEC file cleanup patch

Comment 3 Charalampos Stratakis 2016-03-10 11:22:32 UTC
koji scratch build

https://koji.fedoraproject.org/koji/taskinfo?taskID=13260738

Maintainer are ok for the patch to be pushed for this package?

Comment 4 Adel Gadllah 2016-03-10 17:44:04 UTC
Hi, yes patch looks good thanks. Feel free to apply it.

Comment 5 Fedora Update System 2016-03-12 12:19:00 UTC
iotop-0.6-10.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-794825c2b8

Comment 6 Fedora Update System 2016-03-15 18:50:26 UTC
iotop-0.6-10.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-794825c2b8

Comment 7 Fedora Update System 2016-03-26 18:11:06 UTC
iotop-0.6-10.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.