Bug 1282210 - Synaptics backend not found
Synaptics backend not found
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plasma-desktop (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 09:56 EST by Murilo Opsfelder Araujo
Modified: 2016-05-28 12:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-20 02:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log for pc with touchpad issue (31.36 KB, text/plain)
2016-02-17 15:42 EST, info@kobaltwit.be
no flags Details
Screenshot of error message (44.12 KB, image/png)
2016-05-28 12:24 EDT, info@kobaltwit.be
no flags Details

  None (edit)
Description Murilo Opsfelder Araujo 2015-11-15 09:56:49 EST
Description of problem:

On System Settings, select Touchpad, and you will see "Synaptics backend not found" error message.

Version-Release number of selected component (if applicable):

[muriloo@localhost ~]$ rpm -q plasma-desktop
plasma-desktop-5.4.3-1.fc23.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Go to System Settings
2. Select Input Devices
3. Select Touchpad

Actual results:

The error message is displayed: "Synaptics backend not found".

Expected results:

User should be able to configure touchpad settings.

Additional info:

This is related to bug https://bugzilla.redhat.com/show_bug.cgi?id=1199825, which happened with Fedora 22.

I tried removing xorg-x11-drv-libinput-0.14.0-2.fc23.x86_64 package, rebooted, and issue persisted.
Comment 1 info@kobaltwit.be 2016-02-17 15:42 EST
Created attachment 1128010 [details]
Xorg.0.log for pc with touchpad issue

I'm having this same issue on a HP Envy Recline 27". kde-config-touchpad shows "Synaptics backend not found". And no kf5 based application accepts touch input.

On the other hand KDE4 based applications and gtk applications do. So the touchscreen is in fact working to some extent. Only kf5 applications (including plasma and dolphin) fail to use it.

If there is any extra information I can add to get to the core of this bug, please let me know.
Comment 2 info@kobaltwit.be 2016-02-17 15:46:29 EST
Oh, currently installed software versions:
plasma-desktop-5.5.4-1.fc23.x86_64
xorg-x11-drv-synaptics-1.8.3-1.fc23.x86_64
xorg-x11-drv-libinput-0.16.0-1.fc23.x86_64
libinput-1.1.7-1.fc23.x86_64

And on another PC I have a Apple Magic Pad connected. This one does work fine in plasma et al. So it looks like he brand/model of touch screen/touch pad is relevant as well.
Comment 3 Rex Dieter 2016-02-17 15:48:29 EST
pretty sure no chance of synaptics backend working there, since you have no devices supported by synaptics driver.  You *do* have 

[    53.579] (**) Advanced Silicon S.A CoolTouch(TM) System: Applying InputClass "evdev touchscreen catchall"
[    53.579] (**) Advanced Silicon S.A CoolTouch(TM) System: Applying InputClass "libinput touchscreen catchall"
[    53.579] (II) Using input driver 'libinput' for 'Advanced Silicon S.A CoolTouch(TM) System'
[    53.579] (**) Advanced Silicon S.A CoolTouch(TM) System: always reports core events

which should theoretically work with libinput though.
Comment 4 Rajeesh 2016-02-17 16:21:36 EST
(In reply to info@kobaltwit.be from comment #2)
> Oh, currently installed software versions:
> plasma-desktop-5.5.4-1.fc23.x86_64
> xorg-x11-drv-synaptics-1.8.3-1.fc23.x86_64
> xorg-x11-drv-libinput-0.16.0-1.fc23.x86_64
> libinput-1.1.7-1.fc23.x86_64

Can you remove xorg-x11-drv-synaptics, reboot and check? If that doesn't work, does removing libinput and xorg-x11-drv-libinput but leaving xorg-x11-drv-synaptics make any difference?

Anyway, this part of the code is reworked in master branch, hopefully fixing the issue.
Comment 5 info@kobaltwit.be 2016-02-18 04:22:01 EST
(In reply to Rajeesh from comment #4)
> Can you remove xorg-x11-drv-synaptics, reboot and check? If that doesn't
> work, does removing libinput and xorg-x11-drv-libinput but leaving
> xorg-x11-drv-synaptics make any difference?
> 
Thank you for the suggestions. Here are my findings:

Removing xorg-x11-drv-synaptics didn't change anything. The error message in kde-config-touchpad remains, I can't make any changes there and plasma still doesn't respond to screen tapping.

So I reinstalled xorg-x11-drv-synaptics and removed xorg-x11-drv-libinput. The error message in kde-config-touchpad remains. This time however I can tap the screen to open the F-menu, I can manipulate dolphin and so on.

It's still very limited input support though. I can't swipe or drag-scroll, no two-finger tap recognition,...

Also not working is tapping items on the desktop (files and folders listed via the folder-view plasmoid). They don't react to tapping at all. On the other hand I can drag-select on the desktop though. So there is *some* sensitivity there.

So while according to comment 3 libinput should be be able to handle the device, it apparently fails to do so correctly, or at least it doesn't work properly in kf5 based applications.

Whatever input system that takes over in the absence of libinput only provides very basic touch support.

For completeness it may be worth mentioning I have found yet another driver installed on my system which may be touchscreen related.
xorg-x11-drv-wacom-0.30.0-3.fc23.x86_64
Comment 6 Rajeesh 2016-05-19 16:37:00 EDT
This part of the code has been reworked in Plasma 5.6.3. Now that it landed in F23, do you still face this issue?
Comment 7 Murilo Opsfelder Araujo 2016-05-19 19:08:14 EDT
(In reply to Rajeesh from comment #6)
> This part of the code has been reworked in Plasma 5.6.3. Now that it landed
> in F23, do you still face this issue?

Hi, Rajeesh.

I have plasma-desktop-5.6.3-2.fc23.x86_64 and everything is working fine.  Note: I had to remove all ~/.kde* and ~/.config/kde* directories to start fresh.

I think this bug can be closed.

Thanks!
Comment 8 info@kobaltwit.be 2016-05-26 11:36:52 EDT
(In reply to Rajeesh from comment #6)
> This part of the code has been reworked in Plasma 5.6.3. Now that it landed
> in F23, do you still face this issue?

For me there is improvement, but not all is fixed yet:
- Tapping and two-finger tapping now works in dolphin
- It doesn't work on the desktop yet. That is, when I tap on a folder on the desktop (from folder view), nothing happens. It's not selected nor opened.
- kde-config-touchpad still shows "no touch pad found"). Perhaps a touch screen isn't considered a touch pad, however I would expect to be able to define some behaviour here as well.

Note, I didn't remove all ~/.kde* and ~/.config/kde* and don't feel like doing so as there is too much configured already. If someone can tell narrow this down to a small number of related config files to remove I'm willing to do so.
Comment 9 info@kobaltwit.be 2016-05-26 11:38:19 EDT
I was wondering also, now this bug is closed should I open a new one ? (I'm not even sure I'm having the exact same problem as the OP).
Comment 10 Rajeesh 2016-05-27 08:26:14 EDT
(In reply to info@kobaltwit.be from comment #8)
> - kde-config-touchpad still shows "no touch pad found").

It would be very strange to still have this message with Plasma 5.6.3.

> 
> Note, I didn't remove all ~/.kde* and ~/.config/kde* and don't feel like
> doing so as there is too much configured already. If someone can tell narrow
> this down to a small number of related config files to remove I'm willing to
> do so.

The config file is ~/.config/touchpadrc.

I think you better file an upstream bug in bugs.kde.org
Comment 11 info@kobaltwit.be 2016-05-28 12:24 EDT
Created attachment 1162597 [details]
Screenshot of error message

Strictly speaking this is not with plasma 5.6.3, apparently the last updates have installed plasma 5.6.4.

In the attached screen shot you can observe the error message in the kcm. I have placed a konsole in front of it displaying the plasma version.
Comment 12 info@kobaltwit.be 2016-05-28 12:27:03 EDT
FWIW, removing the config file makes no difference.

I'll file a bug in the kde bug tracker in a few days (currently out of time).

Note You need to log in before you can comment on or make changes to this bug.