Bug 1282223 - An error occurred while rendering image.
An error occurred while rendering image.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: photocollage (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adrien Vergé
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 11:26 EST by Grégoire
Modified: 2016-05-19 05:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: photocollage-1.3.1-1.fc23 photocollage-1.3.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 19:23:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grégoire 2015-11-15 11:26:53 EST
Description of problem: When adding images (click on "add images" button and select some images from my hard-drive), I get an error message saying: "An error occurred while rendering image."

Version-Release number of selected component (if applicable): I couldn't find a version number or an 'about' dialog.


How reproducible: reproducible


Steps to Reproduce:
1. Open photocollage
2. click "add images"
3. select some image and click OK

Actual results:
Error message, no image generated

Expected results:
Generates a collage (I guess, since I haven't tried it before)

Additional info: Python traceback (when launched from the terminal):
Traceback (most recent call last):
  File "/usr/lib64/python3.4/multiprocessing/process.py", line 254, in _bootstrap
    self.run()
  File "/usr/lib/python3.4/site-packages/photocollage/render.py", line 145, in run
    self.wr_conn.send(self.fn(*self.fn_args, **self.fn_kwargs))
  File "/usr/lib/python3.4/site-packages/photocollage/render.py", line 288, in resize_photo
    return img.size[0], img.size[1], img.tostring()
  File "/usr/lib64/python3.4/site-packages/PIL/Image.py", line 686, in tostring
    "Please call tobytes() instead.")
Exception: tostring() has been removed. Please call tobytes() instead.
Comment 1 Adrien Vergé 2015-11-15 16:24:37 EST
Thanks for reporting this Grégoire. I'll fix it as soon as possible.
Comment 2 Fedora Update System 2015-11-15 16:28:47 EST
photocollage-1.3.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-52acbb5c7f
Comment 3 Fedora Update System 2015-11-15 23:50:39 EST
photocollage-1.3.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update photocollage'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-52acbb5c7f
Comment 4 Fedora Update System 2015-11-16 00:53:00 EST
photocollage-1.3.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update photocollage'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-941d227568
Comment 5 Grégoire 2015-11-16 05:28:36 EST
That was fast! Thanks
Comment 6 Adrien Vergé 2015-11-16 12:01:34 EST
Actually the problem was already fixed, just waiting for a version bump to have a new release ;)
Comment 7 Fedora Update System 2015-11-22 19:23:05 EST
photocollage-1.3.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-12-05 22:19:56 EST
photocollage-1.3.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Jon Ingason 2016-05-19 05:27:01 EDT
Just installed photocollage-1.3.2-1.fc22 and are getting "An error occurred while rendering image" when I try to load an image.

Note You need to log in before you can comment on or make changes to this bug.