Bug 1282226 - Incorrect Commands for Verifying Checksums on Windows 10
Incorrect Commands for Verifying Checksums on Windows 10
Status: CLOSED DUPLICATE of bug 1175759
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Windows
unspecified Severity medium
: ---
: ---
Assigned To: Petr Bokoc
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 11:52 EST by Adam Stewart
Modified: 2016-02-02 09:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 09:30:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stewart 2015-11-15 11:52:10 EST
Description of problem:

I tried the instructions for verifying checksums on Windows (section 3.3.1) but ran into a problem.

Version-Release number of selected component (if applicable):

Fedora 23 iso download, Windows 10 computer

How reproducible:

Follow the instructions detailed in section 3.3.1 of the install-guide on a Windows 10 computer.

Steps to Reproduce:

1. Download the Fedora checksum file
2. Open a powershell session
3. Change to the directory containing the checksum file
4. Run the following commands:

> $image = "Fedora-Server-DVD-x86_64-21.iso"
> $checksum_file = "Fedora-Server-21-x86_64-CHECKSUM"
> $sha256 = New-Object -TypeName System.Security.Cryptography.sha256CryptoServiceProvider
> $expected_checksum = ((Get-Content $checksum_file | Select-String -Pattern $image) -split " ")[0].ToLower()
> echo "Expected Checksum: $expected_checksum"

Actual results:

"sha256sum"

Expected results:

"a91eca2492ac84909953ef27040f9b61d8525f7ec5e89f6430319f49f9f823fe"

Additional info:

The correct checksum is actually in the fourth and final position of the string after being split. I recommend replacing the [0] in the instructions with a [-1], assuming that you are able to recreate this problem. If not, let me know and I'll try to provide a more detailed report.
Comment 1 Pete Travis 2016-02-02 09:30:53 EST

*** This bug has been marked as a duplicate of bug 1175759 ***

Note You need to log in before you can comment on or make changes to this bug.