Bug 1282231 - Difficulty assigning nodes
Difficulty assigning nodes
Status: VERIFIED
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: TP3
: 1.0
Assigned To: Erik Nelson
Landon LaSmith
Dan Macpherson
: Triaged
Depends On:
Blocks: rhci-sprint-14
  Show dependency treegraph
 
Reported: 2015-11-15 12:13 EST by Thom Carlin
Modified: 2016-04-29 12:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-11-15 12:13:59 EST
Description of problem:

When assigning Deployment Nodes to roles, most methods of assigning roles didn't work.

Version-Release number of selected component (if applicable):

TP2

How reproducible:

100%

Steps to Reproduce:
1. Install RHCI
2. Install Triple-O
3. During Deployment, install OpenStack
4. In Assign Nodes, try to assign a role using drag-and-drop OR edit role.

Actual results:

Fails to assign role.

Expected results:

Any of the 3 methods should either assign the role or not be available.

Additional info:

only method that worked was to click "Assign Role" within the Node.
Comment 1 Jason Montleon 2016-01-18 13:55:10 EST
Drag and drop works, but what may not be apparent is that the mouse cursor must be inside the Assign Nodes box when you release. The edit role method does not work for me either.
Comment 2 Erik Nelson 2016-03-07 15:55:41 EST
Drag and drop was due to a browser inconsistency in Chrome, should be fixed as of the latest iso.

https://github.com/fusor/fusor/pull/696
Comment 3 John Matthews 2016-03-23 12:56:11 EDT
Available in TP3 RC#2
Comment 4 Landon LaSmith 2016-04-12 19:31:37 EDT
ISO version: TP3 RC3

I was able to use drag and drop to accurately assign nodes. I tested that nodes would only assign when the mouse cursor was in the "Assign Role" box. Using "Assign Role" to select the role worked.

I was unable to use edit role (pencil icon) to update the role count. Change the role count and saving the change was not reflected/updated in the Web ui.
Comment 5 Landon LaSmith 2016-04-14 10:49:17 EDT
Marking as VERIFIED since the drag and drop functionality has been fixed. Open another bug to track "Edit Role" bug

Note You need to log in before you can comment on or make changes to this bug.