Bug 1282285 - Sound 'Chipmunks' on playback with Jabra Evolve 65 UC Headset
Sound 'Chipmunks' on playback with Jabra Evolve 65 UC Headset
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 21:50 EST by gizmo
Modified: 2016-07-19 16:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 16:15:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gizmo 2015-11-15 21:50:21 EST
Description of problem:
When playing audio through the Jabra Evolve 65 UC headset using either the USB cable or the Jabra Link 360 USB dongle, sound is played back too fast, with a 'chipmunk' effect.  I don't know if the recording side is affected or not, but people have not commented on it if it is.

Version-Release number of selected component (if applicable):
Name        : pulseaudio
Arch        : x86_64
Epoch       : 0
Version     : 6.0
Release     : 8.fc22
Size        : 3.3 M
Repo        : @System

Name        : alsa-plugins-pulseaudio
Arch        : i686
Epoch       : 0
Version     : 1.0.29
Release     : 1.fc22
Size        : 101 k
Repo        : @System


How reproducible:
Always

Steps to Reproduce:
1. Plug in headset using USB cable.
2. Play audio

Actual results:
Audio plays fast.  Buffered audio streams (like youtube) play without gaps, but realtime streams (like Skype, or Jabber) play with gaps.

Expected results:
Audio should play back at the normal rate with no gaps.

Additional info:
My Logitech USB headset plays just fine.

When using the Jabra headset in BlueTooth mode, audio playback is normal using either the A2DP audio profile or the HSP/HFP.

When connected with the USB cable lsusb reports the Jabra device as:
Bus 001 Device 008: ID 0b0e:030b GN Netcom

The Jabra device plays just fine on Windows, using the same computer.

System is running KDE with Phonon GStreamer and alsa.

I honestly don't know if this is a Pulse problem or an ALSA problem.
Comment 1 gizmo 2016-01-26 15:16:12 EST
This bug has been open now for 2 months with zero movement.  Is there anything I can do to help out here?  I'm willing to troubleshoot, I just have no idea what to do next.
Comment 2 Wim Taymans 2016-01-29 13:50:29 EST
I'm pretty sure that this is an alsa problem. The driver probably configures the wrong samplerate or maybe it needs a tweak for this particular hardware.
Comment 3 joerg.pareigis 2016-02-15 12:11:38 EST
Exactly the same here.
Trying with newest version of Debian 8 and SuSE 42.1.

The headset plays too fast with a short gap every second. Regardless which connection is used. Directly via USB-Cable, or via BT-Dongle. Both with the same result.

It plays the correct speed when connected via Bluetooth to Android devices.
Connected at Windows PC it pays also without any spot.
Comment 4 gizmo 2016-02-15 14:13:10 EST
(In reply to Wim Taymans from comment #2)
> I'm pretty sure that this is an alsa problem. The driver probably configures
> the wrong samplerate or maybe it needs a tweak for this particular hardware.

Ok, so I've got the same question; what can I do to help troubleshoot this?  Guys, I'm willing to be your eyes and hands here, but these eyes and hands need a brain to direct them. :)
Comment 5 Oleksandr 2016-03-05 17:15:20 EST
Hi. I've had the same problem.
Here is workaround that helped me:

In file

/etc/pulse/daemon.conf

replace
---
;default-sample-rate = 44100

|
v

with
---
default-sample-rate = 48000

And then reload pulseaudio

pulseaudio -k
Comment 6 gizmo 2016-03-07 22:56:03 EST
Just tried this, and it appears to work here as well.
Comment 7 Fedora End Of Life 2016-07-19 16:15:30 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.