Bug 1282315 - Data Tiering:Metadata changes to a file should not heat/promote the file
Data Tiering:Metadata changes to a file should not heat/promote the file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1278754 1279166
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 23:55 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279166
Environment:
Last Closed: 2016-04-19 03:48:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-15 23:59:37 EST
REVIEW: http://review.gluster.org/12582 (tier/ctr: Providing option to record or ignore metadata heat) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-11-16 10:42:45 EST
COMMIT: http://review.gluster.org/12582 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit a1aa8e72b026f4abbec743d6a12ab42263ccdaee
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Sun Nov 8 15:33:15 2015 +0530

    tier/ctr: Providing option to record or ignore metadata heat
    
    Currently we heat up a file for both data and metadata write.
    Here we provide a ctr xlator option called "ctr-record-metadata-heat"
    were the admin can decide on recording metadata heat i.e heatup a
    file on metadata writes or not.
    Metadata data operation are
    a. setattr: explicit changing of atime/mtime using utimes,
                changing of posix permissions of the file
    b. rename: Renaming a file,
    c. unlink, link: adding or deleting hardlinks
    d. xattrs: setting or removal of xattrs.
    
    NOTE: atime, mtime and ctime change through writev, readv, truncate, mknod
    and create will not be considered here as these fops are data and primary
    metadata fops.
    
    Defaultly "ctr-record-metadata-heat" is off. Admin can
    switch it on using gluster volume set command.
    
    Backport of http://review.gluster.org/12540
    
    > Change-Id: I91157509255dd5cb429cda2b6d4f64582e155e7b
    > BUG: 1279166
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12540
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I986c319f0cc337b0692a1dd02f71254e786afac4
    BUG: 1282315
    Reviewed-on: http://review.gluster.org/12582
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:48:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.