Bug 1282328 - Fact required for tripleo to provide IPv6 support
Fact required for tripleo to provide IPv6 support
Status: CLOSED DUPLICATE of bug 1283387
Product: RDO
Classification: Community
Component: openstack-tripleo (Show other bugs)
trunk
Unspecified Unspecified
high Severity high
: GA
: trunk
Assigned To: hguemar
yeylon@redhat.com
: Reopened
Depends On:
Blocks: 1280523
  Show dependency treegraph
 
Reported: 2015-11-16 01:51 EST by Gilles Dubreuil
Modified: 2016-04-18 02:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 01:10:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1283387 None None None Never

  None (edit)
Description Gilles Dubreuil 2015-11-16 01:51:53 EST
Description of problem:
Current version family of Facter 2.4 doesn't entirely support IPv6

The netmask6 facts are missing.

This can be reproduced:
1. Install facter
# yum install -y facter

2.By default IPv6 is active and at least the loopback interface (::1) should be set:
# ip addr show lo
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever


3. Try to obtain a netmask6 fact
# facter netmask6_lo

Actual results:
Nothing is returned

Expected results:
# facter netmask6_lo
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
Comment 2 Dan Sneddon 2015-11-18 15:49:03 EST

*** This bug has been marked as a duplicate of bug 1283387 ***
Comment 3 Gilles Dubreuil 2015-11-19 16:18:57 EST
I'm reopening this one because this specifically for RDO where BZ#1283387 is for RHOS (OSP).

That said I can't find a facter component in RDO.

It's more likely Openstack Repos to provide facter 3.x before vanilla RHEL/CENTOS/Fedora will have it.
Comment 4 Gilles Dubreuil 2015-11-19 17:03:47 EST
Facter 3+ facts
---------------
There are many new facts in Facter 3.

Facter 3.1 contains much more facts than Facter 2.4:
http://docs.puppetlabs.com/facter/2.4/core_facts.html
https://docs.puppetlabs.com/facter/3.0/core_facts.html

Also the facts are now structured by default (still accessible the standard way)

Also Facter 3.1 is the recommended version to use for the Puppet open source version while Facter 4.1 is the one for Puppet Enterprise 3.8


Backporting
-----------

I'm not sure netmask6 can be backported to 2.4, seems like there are many issues around ipv6 and some of them might be structural. 

On the long run we need to get going with Facter 3 anyway.

Build
----- 

It might effectively take a while until Fedora/EPEL repos provides Facter3, this is why, as we have been doing before, make the package available as part of Openstack Repos.

Note: To build latest Facter version 3.1.1, I had to use Fedora because it requires boost version >= 1.54
Comment 5 Gilles Dubreuil 2015-12-04 01:10:34 EST
After some dependencies reorganisation around BZ#1280523, BZ#=1283387 and BZ#1283387, this one can be closed.

*** This bug has been marked as a duplicate of bug 1283387 ***

Note You need to log in before you can comment on or make changes to this bug.