Bug 1282370 - The uninstall playbook should remove the master api and controllers configuration
The uninstall playbook should remove the master api and controllers configura...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 04:02 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 16:19:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-11-16 04:02:45 EST
Description of problem:
The uninstall playbook should remove the master api and controllers configuration 

Version-Release number of selected component (if applicable):
https://github.com/openshift/openshift-ansible master

How reproducible:
Always


Steps to Reproduce:

1. uninstall the ha-master env
2. check the configuraion file
#ll /etc/sysconfig/atomic-openshift-*
# ll /etc/systemd/system/atomic-openshift-*



Actual results:
#ll /etc/sysconfig/atomic-openshift-*
-rw-r--r--. 1 root root  380 Nov 16 14:35 /etc/sysconfig/atomic-openshift-master-api
-rw-r--r--. 1 root root  344 Nov 16 14:35 /etc/sysconfig/atomic-openshift-master-controllers
-rw-r--r--. 1 root root  314 Nov 16 15:43 /etc/sysconfig/atomic-openshift-master.rpmsave
-rw-r--r--. 1 root root 1060 Nov 16 15:49 /etc/sysconfig/atomic-openshift-node.rpmsave
# ll /etc/systemd/system/atomic-openshift-*
total 0
lrwxrwxrwx. 1 root root 59 Nov 16 14:35 atomic-openshift-master-api.service -> /usr/lib/systemd/system/atomic-openshift-master-api.service
lrwxrwxrwx. 1 root root 67 Nov 16 14:35 atomic-openshift-master-controllers.service -> /usr/lib/systemd/system/atomic-openshift-master-controllers.service



Expected results:
The configuration files should be removed.

Additional info:
Comment 1 Jason DeTiberus 2015-11-16 13:07:09 EST
https://github.com/openshift/openshift-ansible/pull/904
Comment 2 Ma xiaoqiang 2015-11-16 21:53:06 EST
Pls delete /etc/systemd/system/atomic-openshift-node.service.wants too.
Comment 3 Jason DeTiberus 2015-11-18 15:26:42 EST
I created https://github.com/openshift/openshift-ansible/pull/936 to remove the node service wants file.
Comment 4 Ma xiaoqiang 2015-11-18 23:58:25 EST
Get the expected result, move it to VERIFIED.
Comment 6 errata-xmlrpc 2015-12-17 16:19:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2667

Note You need to log in before you can comment on or make changes to this bug.