Bug 1282393 - Wrong options name ETCD_SNAPSHOT_COUNTER in /etc/etcd/etcd.conf
Wrong options name ETCD_SNAPSHOT_COUNTER in /etc/etcd/etcd.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: etcd (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
atomic-bugs@redhat.com
: EasyFix, Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 04:59 EST by Joy Pu
Modified: 2016-02-16 11:40 EST (History)
0 users

See Also:
Fixed In Version: etcd-2.1.1-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 11:40:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0231 normal SHIPPED_LIVE etcd bug fix and enhancement update 2016-02-16 16:39:11 EST

  None (edit)
Description Joy Pu 2015-11-16 04:59:36 EST
Description of problem:
The option "ETCD_SNAPSHOT_COUNTER" should be "ETCD_SNAPSHOT_COUNT".


Version-Release number of selected component (if applicable):
etcd.x86_64 0:2.1.1-3.el7

How reproducible:
100%


Steps to Reproduce:
1. Copy the line of ETCD_SNAPSHOT_COUNTER and remove the '#'
2. Set the value to 10 and restart etcd service
3. Check /var/lib/etcd/default.etcd/member/snap/ directory for the file name
4. Two nearby files name should fit b minus a is 10(as set in step 2).
5. After change it to ETCD_SNAPSHOT_COUNT it can work as expect.

Actual results:
The snap files is not generated every 10 times.


Expected results:
The snap files is separated every 10 times.


Additional info:
Comment 4 Joy Pu 2016-01-11 08:24:43 EST
Checked with following steps and seems it is fixed in etcd-2.2.2-5.el7
1. check the etcd.conf file
# cat /etc/etcd/etcd.conf |grep COUNT
#ETCD_SNAPSHOT_COUNT="10000"

2. test with the reproduce steps and it works as expect.
1) set ETCD_SNAPSHOT_COUNTER to 10 in etcd.conf
2) restart etcd service
3) check etcd service status with -l
Jan 11 16:24:03 dhcp-73-2-65.eng.pek2.redhat.com etcd[5513]: start to snapshot (applied: 1215132, lastsnap: 1215121)
Jan 11 16:24:03 dhcp-73-2-65.eng.pek2.redhat.com etcd[5513]: saved snapshot at index 1215132
Jan 11 16:24:09 dhcp-73-2-65.eng.pek2.redhat.com etcd[5513]: start to snapshot (applied: 1215143, lastsnap: 1215132)
Jan 11 16:24:09 dhcp-73-2-65.eng.pek2.redhat.com etcd[5513]: saved snapshot at index 1215143



So update this one to VERIFIED
Comment 6 errata-xmlrpc 2016-02-16 11:40:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0231.html

Note You need to log in before you can comment on or make changes to this bug.