Bug 1282397 - [Fedora Only] engine-backup fails with: tar: '--same-order' cannot be used with '-c'
[Fedora Only] engine-backup fails with: tar: '--same-order' cannot be used wi...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backup-Restore.Engine (Show other bugs)
3.6.0
All Linux
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Yedidyah Bar David
Gonza
integration
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 05:09 EST by christian.grundmann
Modified: 2015-12-16 07:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:17:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
bmcclain: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48596 master MERGED packaging: engine-backup: Do not pass -s with -c Never
oVirt gerrit 48659 ovirt-engine-3.6 MERGED packaging: engine-backup: Log tar creation failures Never
oVirt gerrit 48660 ovirt-engine-3.6 MERGED packaging: engine-backup: Do not pass -s with -c Never

  None (edit)
Description christian.grundmann 2015-11-16 05:09:28 EST
Description of problem:
on FC22 engine-backup fails with 
tar: '--same-order' cannot be used with '-c'

Version-Release number of selected component (if applicable):
3.6.0.3-1.fc22


Steps to Reproduce:
1. engine-backup --mode=backup --scope=all --file backup
2. Fails with error
3.

Additional info:
The Patch from https://gerrit.ovirt.org/#/c/48596/ works for me
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-16 05:42:36 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Gonza 2015-11-25 10:52:49 EST
Verified with:
ovirt-engine-3.6.2-0.0.master.20151124181807.git6d4897e.fc22.noarch

# engine-backup --mode=backup --scope=all --file=backup --log=bkp.log
Backing up:
Notifying engine
- Files
- Engine database 'engine'
Packing into file 'backup'
Notifying engine
Done.
Comment 3 Sandro Bonazzola 2015-12-16 07:17:44 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.