Bug 1282405 - Backword-incompatible update
Backword-incompatible update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libqtxdg (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On: libqtxdg-qt4
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 05:20 EST by Eugene A. Pivnev
Modified: 2016-02-09 18:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 18:45:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene A. Pivnev 2015-11-16 05:20:06 EST
Description of problem:

libqtxdg-1.3.0 replaces 1.2.0 but it brackes packages that require libqtxdg-qt4 (e.g. razorqt).
Herewith 1.2.0 (qt4) and 1.3.0 (qt5) can be installed together.

I propose return libqtxdg back to 1.2.0 and create something like libqt5xdg-1.3.0.
Comment 1 Rex Dieter 2015-11-22 10:44:40 EST
Agreed, looks like a new libqtxdg-qt4-1.2.0 pkg needs to be created, to avoid broken dependencies.
Comment 2 Rex Dieter 2015-11-22 14:21:59 EST
Here's a quick-n-dirty one I whipped up based on the last 1.2.0 builds,

https://rdieter.fedorapeople.org/rpms/libqtxdg/

I can submit for review soon (no one beats me to it), provided one of you would be interested in helping to review it.
Comment 3 Eugene A. Pivnev 2015-11-22 15:50:08 EST
(In reply to Rex Dieter from comment #2)
> Here's a quick-n-dirty one I whipped up based on the last 1.2.0 builds,
> 
> https://rdieter.fedorapeople.org/rpms/libqtxdg/
> 
> I can submit for review soon (no one beats me to it), provided one of you
> would be interested in helping to review it.

I can review.
Comment 4 Rex Dieter 2015-11-28 18:50:17 EST
OK, submitted
https://bugzilla.redhat.com/show_bug.cgi?id=1286395
for review
Comment 5 Rex Dieter 2015-12-07 14:28:02 EST
ping, see bug #1286395, review has been waiting now for over a week
Comment 6 Rex Dieter 2016-02-09 18:45:22 EST
Compatible libqtxdg-qt4 is now available in updates, closing.

Note You need to log in before you can comment on or make changes to this bug.