Bug 1282410 - pki-server dropped dependency on non-headless java but added dependency on nuxwdog-client-java which pulls it back
pki-server dropped dependency on non-headless java but added dependency on nu...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nuxwdog (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ade Lee
Asha Akkiangady
: ZStream
Depends On:
Blocks: 1283338
  Show dependency treegraph
 
Reported: 2015-11-16 05:39 EST by Jan Pazdziora
Modified: 2016-11-04 03:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: nuxwdog-1.0.3-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1283338 (view as bug list)
Environment:
Last Closed: 2016-11-04 03:35:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-11-16 05:39:00 EST
Description of problem:

Up to RHEL 7.1, pki-server (and other pki-* packages) depended on java, non-headless. That pulled huge list of dependencies when IdM was installed.

In RHEL 7.2, those dependencies have changed to java-headless ... but pki-server added new dependency on nuxwdog-client-java. That package pulls the non-headless java dependencies right back.

Version-Release number of selected component (if applicable):

pki-server-10.2.5-6.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. yum install -y pki-server

Actual results:

Both java-1.7.0-openjdk and java-1.8.0-openjdk get installed.

Expected results:

Neither java-1.7.0-openjdk nor java-1.8.0-openjdk gets installed.

Additional info:
Comment 2 Ade Lee 2015-11-18 13:24:41 EST
remote: *** Checking commit 1bb9678cef08caef107a3a5a35537283b1e4be95
remote: *** Resolves:
remote: ***   Approved:
remote: ***     rhbz#1282410 (rhel-7.2.z?, pm_ack+, rhel-7.3.0+)
remote: *** Commit 1bb9678cef08caef107a3a5a35537283b1e4be95 allowed
To ssh://alee@pkgs.devel.redhat.com/rpms/nuxwdog
   b6107d4..1bb9678  rhel-7.3 -> rhel-7.3
Comment 5 Roshni 2016-07-29 16:46:03 EDT
Verified as explained in https://bugzilla.redhat.com/show_bug.cgi?id=1283338#c6
Comment 7 errata-xmlrpc 2016-11-04 03:35:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2488.html

Note You need to log in before you can comment on or make changes to this bug.